summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-28 20:55:44 +0200
committerPellegrino Prevete2023-06-28 20:55:44 +0200
commit1ae477b0857c1204a9f00527135a56fad6a73304 (patch)
tree4fa27f46c43e492f0c0b8c6dbb3354389ea33c3b /PKGBUILD
parent7477f687850b9abfdbd7f38b202ded30e6095bee (diff)
downloadaur-devhelp-git.tar.gz
update to 43.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 61 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 264d693d8057..8b20726bb0d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,56 @@
-pkgname=devhelp-git
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
_pkgname=devhelp
-pkgver=3.38.0+4+g5eb0b92c
+pkgbase="${_pkgname}-git"
+pkgname=(
+ "${pkgbase}"
+ "${_pkgname}-docs-git"
+)
+pkgver=43.0+9+g4d15da51
pkgrel=1
pkgdesc="API documentation browser for GNOME"
-arch=(x86_64)
-license=(GPL)
url="https://wiki.gnome.org/Apps/Devhelp"
-depends=('webkit2gtk' 'amtk')
-makedepends=('gtk-doc' 'git' 'appstream-glib' 'gobject-introspection' 'meson' 'yelp-tools')
-provides=('devhelp')
-conflicts=('devhelp')
-source=("git+https://gitlab.gnome.org/GNOME/devhelp.git")
+arch=(
+ x86_64
+ i686
+ pentium4
+ aarch64
+ armv7h
+)
+license=(GPL)
+depends=(
+ webkit2gtk-4.1
+)
+makedepends=(
+ appstream-glib
+ git
+ gi-docgen
+ gobject-introspection
+ meson
+ yelp-tools
+)
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd "${_pkgname}"
+}
+
build() {
- arch-meson $_pkgname build -D gtk_doc=true
+ local meson_options=(
+ -D gtk_doc=true
+ -D plugin_emacs=true
+ -D plugin_gedit=true
+ -D plugin_vim=true
+ )
+ arch-meson "${_pkgname}" build "${meson_options[@]}"
meson compile -C build
}
@@ -27,6 +58,23 @@ check() {
meson test -C build --print-errorlogs
}
-package() {
- DESTDIR="$pkgdir" meson install -C build
+package_devhelp-git() {
+ groups=(
+ gnome-extra
+ gnome-extra-git
+ )
+ meson install -C build --destdir "${pkgdir}"
+
+ # Split -docs
+ mkdir -p docs/usr/share
+ mv -t docs/usr/share "$pkgdir"/usr/share/doc
}
+
+package_devhelp-docs-git() {
+ pkgdesc+=" (documentation)"
+ depends=()
+
+ mv -t "$pkgdir" docs/*
+}
+
+# vim:set sw=2 sts=-1 et: