summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302020-01-01 23:48:17 +0100
committerM0Rf302020-01-01 23:48:17 +0100
commit1d7edfc363567a4f6bc6036b3515226571a130a5 (patch)
tree2ed77a534aecfa5ffd5d39101b394423a92b1825 /PKGBUILD
parent37531b662b7100e708b82493141542501113877d (diff)
downloadaur-1d7edfc363567a4f6bc6036b3515226571a130a5.tar.gz
devilutionx: 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff20d9e024ae..7c3143d2448b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=devilutionX
pkgname=devilutionx
-pkgver=0.5.0
+pkgver=1.0.0
pkgrel=1
pkgdesc="Diablo devolved for linux"
arch=('i686' 'x86_64')
@@ -14,12 +14,11 @@ depends=('freetype2' 'graphite' 'libpng' 'libsodium' 'pcre' 'sdl2_mixer'
makedepends=('cmake' 'gcc-libs')
optdepends=('ttf-charis-sil: CharisSILB.ttf')
install="$pkgname".install
-source=("https://github.com/diasurgical/devilutionX/archive/master.zip"
- #"https://github.com/diasurgical/devilutionX/archive/$pkgver.tar.gz"
+source=("https://github.com/diasurgical/devilutionX/archive/$pkgver.tar.gz"
"$pkgname.png")
prepare() {
- cd "$srcdir/${_pkgname}-master"
+ cd "$srcdir/${_pkgname}-$pkgver"
if [ ! -d build ]; then
mkdir build
fi
@@ -28,12 +27,12 @@ prepare() {
}
build() {
- cd "$srcdir/${_pkgname}-master"
+ cd "$srcdir/${_pkgname}-$pkgver"
cd build
make
}
package() {
- cd "$srcdir/${_pkgname}-master"
+ cd "$srcdir/${_pkgname}-$pkgver"
install -vDm755 build/"$pkgname" "$pkgdir"/usr/bin/"$pkgname"
install -vDm644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
@@ -45,5 +44,5 @@ package() {
"$pkgdir"/usr/share/applications/$pkgname.desktop
}
-md5sums=('SKIP'
+md5sums=('2cc387a742aa124941e418c552ae3e0e'
'c593b446c07608ce2ab2eddac6ce7304')