summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302019-11-17 19:10:06 +0100
committerM0Rf302019-11-17 19:10:06 +0100
commit7db835f43950be6fe6d49275018e35c899e2aa38 (patch)
tree9546c12e2cadccb14e3bfff5a1e1de300878c792 /PKGBUILD
downloadaur-7db835f43950be6fe6d49275018e35c899e2aa38.tar.gz
devilutionx: first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44894c780103
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: robertfoster
+# Contributor: LIN Rs <LinRs[d]users.noreply.github.com>
+
+_pkgname=devilutionX
+pkgname=devilutionx
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Diablo devolved for linux"
+arch=('i686' 'x86_64')
+url="https://github.com/diasurgical/devilutionX"
+license=('custom:unlicense')
+depends=('freetype2' 'graphite' 'libpng' 'libsodium' 'pcre' 'sdl2_mixer'
+'sdl2_ttf' 'sdl2_ttf' 'sdl2_ttf')
+makedepends=('cmake' 'gcc-libs')
+optdepends=('ttf-charis-sil: CharisSILB.ttf')
+install="$pkgname".install
+source=("https://github.com/diasurgical/devilutionX/archive/master.zip"
+ #"https://github.com/diasurgical/devilutionX/archive/$pkgver.tar.gz"
+"$pkgname.png")
+
+prepare() {
+ cd "$srcdir/${_pkgname}-master"
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release
+}
+
+build() {
+ cd "$srcdir/${_pkgname}-master"
+ cd build
+ make
+}
+package() {
+ cd "$srcdir/${_pkgname}-master"
+
+ install -vDm755 build/"$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+ install -vDm644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
+
+ # Installing Icons
+ install -Dm644 ../$pkgname.png \
+ $pkgdir/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 Packaging/fedora/$pkgname.desktop \
+ "$pkgdir"/usr/share/applications/$pkgname.desktop
+}
+
+md5sums=('SKIP'
+'014003a7bcef2f035eddff2ee74b3994')