summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302021-04-06 10:49:44 +0200
committerM0Rf302021-04-06 10:49:44 +0200
commitf8a934b651bc223f0e4ce3c69188d2c29830c342 (patch)
treeb79309d59cad1183f0a742e1a03bb7e3e630f485 /PKGBUILD
parentf3d5008b65e1c8ccd1d8999961fe28c7cdf278fd (diff)
downloadaur-f8a934b651bc223f0e4ce3c69188d2c29830c342.tar.gz
devilutionx: 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6775c8d34fea..f01910c5ae9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: robertfoster
# Contributor: LIN Rs <LinRs[d]users.noreply.github.com>
# Contributor: yochananmarqos <mark.wagie at tutanota dot com>
-
_pkgname=devilutionX
pkgname=devilutionx
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
pkgdesc="Diablo devolved for linux"
arch=('armv6h' 'armv7h' 'arm' 'aarch64' 'i686' 'x86_64')
url="https://github.com/diasurgical/devilutionX"
license=('custom:unlicense')
depends=('graphite' 'libsodium' 'sdl2_mixer' 'sdl2_ttf')
makedepends=('cmake' 'gcc-libs')
-install="$pkgname".install
+install="${pkgname}".install
options=('strip')
-source=("https://github.com/diasurgical/devilutionX/archive/$pkgver.tar.gz")
+source=("https://github.com/diasurgical/devilutionX/archive/${pkgver}.tar.gz")
prepare() {
- cd "$srcdir/${_pkgname}-$pkgver"
+ cd "${srcdir}/${_pkgname}-$pkgver"
if [ -d build ]; then
rm -rf build
fi
@@ -25,20 +24,19 @@ prepare() {
}
build() {
- cd "$srcdir/${_pkgname}-$pkgver/build"
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
cmake .. \
- -DCMAKE_CXX_FLAGS_RELEASE="-D_FORTIFY_SOURCE=0" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DBINARY_RELEASE=ON \
- -DVERSION_NUM="$pkgver"
+ -DVERSION_NUM="${pkgver}"
cmake --build .
}
package() {
- cd "$srcdir/${_pkgname}-$pkgver/build"
- DESTDIR=$pkgdir \
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
+ DESTDIR=${pkgdir} \
cmake --install .
}
-md5sums=('76e7f5219e8f58ee71ab671b13ce3139')
+sha256sums=('63a06043b60a5866933eafcc078052e7f6a5878757c451fe74efb141b94386ac')