summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Daly2020-04-19 11:31:50 -0700
committerWill Daly2020-04-19 11:31:50 -0700
commit0f891d6abcb999882040430821699ff8cd2c6816 (patch)
treec7699fb65c7a3d88c85d1e748a08def1ef770d82 /PKGBUILD
parent82809795ff62bfe3beca076e133ce30c5f6cdd28 (diff)
downloadaur-0f891d6abcb999882040430821699ff8cd2c6816.tar.gz
Set the Rust toolchain to stable
Cargo fails with an error if the user hasn't configured a default toolchain. Passing the RUSTUP_TOOLCHAIN env var to the cargo build/test commands ensures that cargo uses the correct toolchain.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca5fde273d4b..734f1dc6d91d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Will Daly <will.e.daly@gmail.com>
pkgname=devlog
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line tool for tracking your day-to-day software development work."
arch=('x86_64')
url="https://github.com/wedaly/devlog"
@@ -13,12 +13,12 @@ sha512sums=('dce5bc1390f1246b8c3240dc416aa64f2912f9c24df8a2f415a24ef9955e085799b
build() {
cd "$pkgname-$pkgver"
- cargo build --release --locked
+ RUSTUP_TOOLCHAIN=stable cargo build --release --locked
}
check() {
cd "$pkgname-$pkgver"
- cargo test --release --locked
+ RUSTUP_TOOLCHAIN=stable cargo test --release --locked
}
package() {