summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXeonacid2022-05-30 20:03:57 +0800
committerXeonacid2022-05-30 20:03:57 +0800
commit81f3e50c26c365d103ff5e5e03cac85e3a731d7e (patch)
tree21caeff0c2a12aaf9f37e5b8c429f7ae8e4efda9 /PKGBUILD
parent27a9a389029fd1eb5657a96be1381ae7597ded57 (diff)
downloadaur-81f3e50c26c365d103ff5e5e03cac85e3a731d7e.tar.gz
Provide qemu-user-static binfmt file, but with P flag.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94a020f8592e..4a1ccbc7506f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Xeonacid <h.dwwwwww at gmail dot com>
pkgname=devtools-riscv64
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
pkgdesc='Tools for Arch Linux RISC-V package maintainers'
arch=('x86_64' 'riscv64')
license=('GPL')
url='https://github.com/felixonmars/archriscv-packages'
depends=('devtools')
-depends_x86_64=('qemu-user-static' 'binfmt-qemu-static')
+depends_x86_64=('qemu-user-static')
source=(makepkg-riscv64.conf
pacman-extra-riscv64.conf)
+source_x86_64=('z-archriscv-qemu-riscv64.conf')
sha256sums=('c8842d83460d44b873ff56c9ee0c982963ff76e5ed13897e5d7b8d7f0ea7c206'
'fc933f164d21774e7a1435d9fccf87cb05f7b601e89a2ba54b899b2ce1e809df')
+sha256sums_x86_64=('c59273c423e815e4c27e8486632d80a768adddd172119035d48f7c2fac98a87a')
package() {
install -dm755 "$pkgdir"/usr/bin
@@ -23,6 +25,9 @@ package() {
if [[ ! "$CARCH" =~ riscv ]]; then
install -dm755 "$pkgdir"/usr/share/devtools/setarch-aliases.d
echo "$CARCH" > "$pkgdir"/usr/share/devtools/setarch-aliases.d/riscv64
+
+ # binfmt-qemu-static, but with P flag
+ install -Dm644 z-archriscv-qemu-riscv64.conf -t "$pkgdir"/usr/lib/binfmt.d/
fi
}