summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormutantmonkey2013-04-21 16:54:05 -0400
committermutantmonkey2013-04-21 16:54:05 -0400
commitf0737eea6285a1ae3457405267f3cb5a60eadce8 (patch)
treee4e4234cbaa544d7daa3226f21c199e9f6e6dcd6 /PKGBUILD
parent6967b47d7a1e17b894b858682a6301f0b46a068f (diff)
downloadaur-f0737eea6285a1ae3457405267f3cb5a60eadce8.tar.gz
dex-git: use new pacman 4.1 VCS features
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 12 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba0c1b2895d7..b425e9fcc353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Contributor: mutantmonkey <mutantmonkey@gmail.com>
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
pkgname=dex-git
-pkgver=20111116
+_gitname=dex
+pkgver=48.21a763e
pkgrel=1
pkgdesc="A program to execute DesktopEntry files of type Application, primarily for window managers that do not implement the Freedesktop autostart specification"
url="https://github.com/jceb/dex"
@@ -10,36 +11,21 @@ depends=('python2')
makedepends=('git')
provides=('dex')
conflicts=('dex')
-source=()
-md5sums=()
-sha256sums=()
+source=('git+https://github.com/jceb/dex.git')
+sha256sums=('SKIP')
-_gitroot="https://github.com/jceb/dex.git"
-_gitname="dex"
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- sed -i 's/\/usr\/bin\/python/\/usr\/bin\/python2/' dex || return 1
+ cd $_gitname
+ sed -i 's/\/usr\/bin\/python/\/usr\/bin\/python2/' dex
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd $_gitname
install -m755 -D dex $pkgdir/usr/bin/dex
}