summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2018-04-24 12:53:12 +0200
committerChristopher Arndt2018-04-24 12:53:12 +0200
commit2bf26e3dede6f9e5bc3226f6a6208b143bbbf72c (patch)
tree94d2be12c29d58ee2e04c3559240d715882d69d3 /PKGBUILD
parent020ad4412003d0ad6c9a2925dc0706364d19e668 (diff)
downloadaur-2bf26e3dede6f9e5bc3226f6a6208b143bbbf72c.tar.gz
Add workaround for non-working VST plug-in
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 25 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2c7c2ac3c4b..3e9e2570392f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="dexed"
pkgver=0.9.4
-pkgrel=1
+pkgrel=2
pkgdesc="A software synth closely modelled on the Yamaha DX7"
arch=('i686' 'x86_64')
url="http://asb2m10.github.io/dexed/"
@@ -17,27 +17,42 @@ md5sums=('0e69fdcc3c18a8ac083657213a7921a2'
changelog=ChangeLog
-prepare() {
+build() {
+ msg2 "Building Dexed stand-alone..."
cd "$srcdir/${pkgname}-${pkgver}"
-
- msg2 "Enabling JACK audio in Dexed JUCE project file..."
- sed -i -e 's|JUCE_JACK="0"|JUCE_JACK="1"|' Dexed.jucer
+ sed -i \
+ -e 's|JUCE_JACK="0"|JUCE_JACK="1"|' \
+ -e 's|buildVST="1"|buildVST="0"|' \
+ Dexed.jucer
Projucer --resave Dexed.jucer
-}
-build() {
cd "${srcdir}/${pkgname}-${pkgver}/Builds/Linux"
+ make CONFIG=Release
+ cp -f build/Dexed "${srcdir}/${pkgname}-${pkgver}"
+ msg2 "Building Dexed VST plug-in..."
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i \
+ -e 's|JUCE_ALSA="1"|JUCE_ALSA="0"|' \
+ -e 's|JUCE_JACK="1"|JUCE_JACK="0"|' \
+ -e 's|buildVST="0"|buildVST="1"|' \
+ -e 's|buildStandalone="1"|buildStandalone="0"|' \
+ Dexed.jucer
+ Projucer --resave Dexed.jucer
+
+ cd "${srcdir}/${pkgname}-${pkgver}/Builds/Linux"
+ make clean
make CONFIG=Release
+ cp -f build/Dexed.so "${srcdir}/${pkgname}-${pkgver}"
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # install VST plugin
- install -Dm755 Builds/Linux/build/Dexed.so "${pkgdir}/usr/lib/vst/Dexed.so"
# install standalone program
- install -Dm755 Builds/Linux/build/Dexed "${pkgdir}/usr/bin/dexed"
+ install -Dm755 Dexed "${pkgdir}/usr/bin/dexed"
+ # install VST plugin
+ install -Dm755 Dexed.so "${pkgdir}/usr/lib/vst/Dexed.so"
# install icon and desktop file
install -Dm755 Resources/ui/dexedIcon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/dexed.png"