summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2021-03-05 17:40:29 +0100
committerChristopher Arndt2021-03-05 17:40:29 +0100
commitc1dd8207c45603aca46af5b27878d74f825a2949 (patch)
treedaa8c02eb2ad38bcdd3f381311eafc9e2ce8d4e5 /PKGBUILD
parenta61b60fb22cfa3b87ddef94854d144ef986425be (diff)
downloadaur-c1dd8207c45603aca46af5b27878d74f825a2949.tar.gz
Extensive PKGBUILD update for upstream version 0.9.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 55 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21b5fb46f388..ce4e9ede35bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,80 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Global assoc. array of it git hashes of
+# thirdparty libs sub-modules at tag for release version
+declare -g -A _thirdparty_libs=(
+ ['surge-synthesizer;surgesynthteam_tuningui']='0cfaa86484733187af78bc3a48bb89e59e64393f'
+ ['surge-synthesizer;tuning-library']='ea580e666e4b0825d7d9e2906407e186e38dd394'
+ ['steinbergmedia;vst3sdk']='0908f475f52af56682321192d800ef25d1823dd2'
+)
+
pkgname="dexed"
-pkgver=0.9.4
-pkgrel=5
+pkgver=0.9.6
+_juce_version=6.0.7
+pkgrel=1
pkgdesc="A software synth closely modelled on the Yamaha DX7"
arch=('i686' 'x86_64')
url="http://asb2m10.github.io/dexed/"
license=("GPL3")
groups=('pro-audio' 'vst-plugins')
-depends=('alsa-lib' 'curl' 'hicolor-icon-theme' 'freetype2' 'libxinerama')
-makedepends=()
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/asb2m10/dexed/archive/v${pkgver}.tar.gz"
- 'dexed.desktop'
- 'juce-pixel-format.patch'
- 'juce-alsa.patch')
-md5sums=('0e69fdcc3c18a8ac083657213a7921a2'
- 'd888f8f2c1a44ed75c77d43faee73361'
- '3b8cd62ca811638639c7f6de18306849'
- 'a5eb7812e4b8719547d6c7ba193d2e53')
+depends=('hicolor-icon-theme' 'libpng')
+makedepends=('alsa-lib' 'curl' 'freetype2' 'jack' 'libx11' 'libxrandr'
+ 'libxinerama' 'libxcursor')
changelog=ChangeLog
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/asb2m10/dexed/archive/v${pkgver}.tar.gz"
+ "https://github.com/juce-framework/JUCE/releases/download/${_juce_version}/juce-${_juce_version}-linux.zip"
+ 'dexed.desktop')
+
+# Add thirdparty libs to source array
+for _proj in "${!_thirdparty_libs[@]}"; do
+ _arr=(${_proj//;/ })
+ _vendor=${_arr[0]}
+ _lib=${_arr[1]}
+ _hash=${_thirdparty_libs[$_proj]}
+ source+=("${_lib}-${_hash}.tar.gz::https://github.com/${_vendor}/${_lib}/archive/${_hash}.tar.gz")
+done
+md5sums=('7dae0fe19ceefed603bef5ccf96140f1'
+ '8beda8acb99a1ae7505eed909bd3e7ea'
+ 'd888f8f2c1a44ed75c77d43faee73361'
+ '448948468aeb5a798cd4a12f68b07c03'
+ 'c8ad413951b5c2adb98ff7fe15bc2db7'
+ '059366b39f4f4588aff66fd6b921a2d8')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # https://github.com/asb2m10/dexed/pull/184
- patch -N -r - -p1 -i "${srcdir}/juce-alsa.patch" || :
- # patch JUCE to compile with GCC >= 9.x
- patch -N -r - -p1 -i "${srcdir}/juce-pixel-format.patch" || return 0
+
+ # Link thirdparty sources to lib/ dir
+ for _proj in "${!_thirdparty_libs[@]}"; do
+ _arr=(${_proj//;/ })
+ _vendor=${_arr[0]}
+ _lib=${_arr[1]}
+ _hash=${_thirdparty_libs[$_proj]}
+
+ if [[ -d libs/${_lib} ]]; then
+ rmdir libs/${_lib}
+ fi
+
+ ln -s "${srcdir}/${_lib}-${_hash}" libs/${_lib}
+ done
+
+ mkdir -p assets
+ ln -sf "${srcdir}/JUCE" assets
+ ./assets/JUCE/Projucer --resave Dexed.jucer
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}/Builds/Linux"
- make \
- CONFIG=Release \
- CXXFLAGS="-D JUCE_JACK=1 -D JUCE_ALSA=1 -D buildVST=1 -D buildStandalone=1"
+ make CONFIG=Release
}
package() {
+ depends+=('libasound.so' 'libcurl.so' 'libfreetype.so')
cd "${srcdir}/${pkgname}-${pkgver}"
# install VST plugin
- install -Dm755 Builds/Linux/build/Dexed.so \
- "${pkgdir}/usr/lib/vst/Dexed.so"
+ install -Dm755 Builds/Linux/build/Dexed.vst3/Contents/$(uname -m)-linux/Dexed.so \
+ -t "${pkgdir}/usr/lib/vst/Dexed.vst3/Contents/$(uname -m)-linux/"
# install standalone program
install -Dm755 Builds/Linux/build/Dexed \
"${pkgdir}/usr/bin/dexed"
@@ -50,7 +83,7 @@ package() {
install -Dm755 Resources/ui/dexedIcon.png \
"${pkgdir}/usr/share/icons/hicolor/512x512/apps/dexed.png"
install -Dm755 "${srcdir}/dexed.desktop" \
- "${pkgdir}/usr/share/applications/dexed.desktop"
+ -t "${pkgdir}/usr/share/applications"
}
# vim:set ts=2 sw=2 et: