summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan de Schaetze2019-04-17 17:47:06 +0200
committerSebastiaan de Schaetze2019-04-17 17:47:06 +0200
commit52d5e58333630c9f70e0d009494fb2902dd5c575 (patch)
tree90ab14a3769290fb0f1e78b90845934c357520d1 /PKGBUILD
downloadaur-52d5e58333630c9f70e0d009494fb2902dd5c575.tar.gz
Initial commit of the Dexed IDE
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98eef57098a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Sebastiaan de Schaetzen <sebastiaan.de.schaetzen@gmail.com>
+pkgname=dexed-ide
+pkgver=3.7.9
+pkgrel=1
+pkgdesc="IDE for the D programming language, its compilers, tools and libraries"
+arch=(x86_64)
+url="https://github.com/Basile-z/dexed"
+license=('Boost')
+depends=(dcd dscanner)
+checkdepends=()
+source=(https://github.com/Basile-z/dexed/releases/download/v3.7.9/dexed.3.7.9.linux64.zip)
+md5sums=('40abfb1d72f22de77338098a155ce14c')
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/dexed-x86_64/{dexed,dastworx} $pkgdir/usr/bin
+}