summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohamar Rios Flores2016-05-22 19:47:21 -0600
committerMohamar Rios Flores2016-05-22 19:47:21 -0600
commit4fad06572599aa91bb000f004eed48dcf3538692 (patch)
tree7d012407188a333f35790cd2819a323a69b7431d /PKGBUILD
downloadaur-4fad06572599aa91bb000f004eed48dcf3538692.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7c431d35544
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mohamar Rios <mohamar.rios@gmail.com>
+pkgname=dexy
+pkgver=1.0.15
+pkgrel=1
+pkgdesc="Open source automation software with features especially designed for documentation and reporting."
+arch=('any')
+url='http://www.dexy.it/'
+license=('MIT')
+depends=('python2'
+ 'python2-beautifulsoup4'
+ 'python2-chardet'
+ 'python2-docutils'
+ 'python2-jinja'
+ 'python2-markdown'
+ 'python2-pexpect'
+ 'python2-ply'
+ 'python2-pygments'
+ 'python2-requests>=0.10.6'
+ 'python2-yaml'
+ 'python2-cashew>=0.2.7'
+ 'python2-dexy-viewer'
+ 'python2-inflection>=0.2.0'
+ 'python2-modargs>=1.7')
+makedepends=('python2-setuptools')
+options=(!emptydirs)
+provides=("${pkgname}")
+source=("https://pypi.python.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "LICENSE::https://raw.githubusercontent.com/dexy/dexy/develop/LICENSE")
+md5sums=('99eb783fdf829b74f4d1f3a801693b86'
+ '7ae0144577340e245b148893690d7f37')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: