summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Werkmeister2017-08-08 01:57:27 +0200
committerLucas Werkmeister2017-08-08 02:55:19 +0200
commitd96a1cc7adc9375ba1e02179dfd1599c07510015 (patch)
tree1616cde26541da16b40a32d67b99666ad8212954 /PKGBUILD
parent8edf52dd3ce745490d0fe90e89c947000b261746 (diff)
downloadaur-d96a1cc7adc9375ba1e02179dfd1599c07510015.tar.gz
Clean up empty directories
The build leaves behind an empty /var/tmp directory with permissions that differ from usual /var/tmp permissions, which causes warnings on package installation. To fix that without too much specific knowledge about any paths, simply delete all empty directories after the build. Also, refresh pkgver.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17985ec75065..be6655546ea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
pkgname=dgsh-git
-pkgver=r1333.89be4ad
+pkgver=r1422.0e51cfd
pkgrel=1
pkgdesc="Directed Graph Shell"
arch=('any')
@@ -54,4 +54,6 @@ check() {
package() {
cd 'dgsh'
make DESTDIR="$pkgdir/" install
+ # the build leaves over some empty directories and sometimes the permissions differ, which produces warnings on install, so clean those up
+ find "$pkgdir" -type d -empty -delete
}