summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 09:50:06 +0200
committerChristian Hesse2015-06-29 09:50:06 +0200
commitbc364cc314a08748f36bd4b99a2c20e19d6fc2a6 (patch)
treee00be7da5702ee5a442620b0feb8812f0106b5b6 /PKGBUILD
downloadaur-bc364cc314a08748f36bd4b99a2c20e19d6fc2a6.tar.gz
initial import of dhcpcd-hook-pdnsd 0.2.0.r2.g596c6be-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340ce6a22294
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=dhcpcd-hook-pdnsd
+pkgver=0.2.0.r2.g596c6be
+pkgrel=1
+pkgdesc="Hook for dhcpcd to add domain name servers to pdnsd (dns caching proxy)"
+arch=('any')
+depends=('pdnsd' 'dhcpcd')
+makedepends=('git')
+url="https://github.com/eworm-de/dhcpcd-hook-pdnsd"
+license=('GPL')
+source=('git://github.com/eworm-de/dhcpcd-hook-pdnsd.git')
+install=dhcpcd-hook-pdnsd.install
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dhcpcd-hook-pdnsd/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ cd dhcpcd-hook-pdnsd/
+
+ make DESTDIR="${pkgdir}" install
+}
+