summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212024-06-11 07:48:55 +0200
committera8212024-06-11 07:48:55 +0200
commit9ca5c8b89e652b1af71a2a2ed361dd04b2435305 (patch)
tree46f1c259b6bd3ee35945dc6274c6c3f57df5d5b7 /PKGBUILD
parent52a486c95b4ac48841951d6edb5d8f401d6d6760 (diff)
downloadaur-9ca5c8b89e652b1af71a2a2ed361dd04b2435305.tar.gz
add xpm-pixbuf-git to depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 267c6b832857..0e93f9798f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,18 @@
pkgname=dia-git
_pkgname=dia
pkgver=6872.aad567a2c
-pkgrel=2
+pkgrel=3
pkgdesc="A GTK+ based diagram creation program"
arch=('x86_64')
license=('GPL-2.0-or-later')
url="https://wiki.gnome.org/action/show/Apps/Dia"
-depends=('poppler' 'python-gobject' 'libxslt' 'gtk3' 'freetype2' 'graphene' 'libemf')
+depends=('poppler' 'python-gobject' 'libxslt' 'gtk3' 'freetype2' 'graphene' 'libemf' 'xpm-pixbuf-git')
makedepends=('git' 'meson' 'intltool' 'dblatex' 'appstream-glib')
provides=('dia')
conflicts=('dia')
options=('docs' '!emptydirs')
-source=("git+https://gitlab.gnome.org/GNOME/dia.git"
- "git+https://gitlab.gnome.org/ZanderBrown/xpm-pixbuf.git")
-sha256sums=('SKIP'
- 'SKIP')
+source=("git+https://gitlab.gnome.org/GNOME/dia.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
@@ -30,11 +28,10 @@ prepare() {
cd "${_pkgname}"
sed -i "s/cc.find_library('ogdf'/cc.find_library('OGDF'/g" meson.build
sed -i 's/gnu++17/gnu++20/' meson.build
- ln -s ../../xpm-pixbuf subprojects
}
build() {
- arch-meson -Ddoc=enabled --force-fallback-for=xpm-pixbuf build ${_pkgname}
+ arch-meson -Ddoc=enabled build ${_pkgname}
ninja -C build
}