summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoruzerus2018-01-07 21:18:18 +0100
committeruzerus2018-01-07 21:18:18 +0100
commit603ebe39ce82af70138e0df3854f397306b772eb (patch)
treeccffcf8f41a9d3e18bc279a76cd2e52cfd47ea6e /PKGBUILD
parent6e2450de15ecd885fa8ce83d4377ec8276eb2a3b (diff)
downloadaur-603ebe39ce82af70138e0df3854f397306b772eb.tar.gz
upgrade and repair
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab81dbcfb96b..14070e1a58b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Uzerus < szymonscholz at gmail.com >
+# Contributor: Justin Dray <justin@dray.be>
# Contributor: Augusto F. Hack <hack.augusto@gmail.com>
pkgname=diamond
-pkgver=4.0.41
+pkgver=4.0.515
pkgrel=3
-pkgdesc="Diamond is daemon that collects system metrics and publishes them to graphite and others"
-arch=(any)
+pkgdesc="Daemon that collects system metrics and publishes
+them to graphite and others"
+arch=('any')
url="https://github.com/python-diamond/Diamond"
license=('mit')
-depends=('python2' 'python2-configobj')
-makedepends=('unzip')
+depends=('python2' 'python')
+makedepends=('')
optdepends=('python2-psycopg2: Postgresql collector'
'python2-pysensors: LMSensors collector'
'libvirt-python: LibvirtKVM collector'
'python2-yaml: PuppetAgent collector')
backup=(etc/diamond/diamond.conf)
-source=("https://pypi.python.org/packages/source/d/diamond/diamond-${pkgver}.tar.gz"
- 'diamond.service')
-md5sums=('063ee62fc30a678260df582335a583c3'
+source=("https://pypi.python.org/packages/0c/b6/4c58a8a1111c138fbed9e65dd918be706af8abd07bb5e8fe3ddfb453d899/${pkgname}-${pkgver}.tar.gz"
+ "https://archive.org/download/${pkgname}_201801/${pkgname}.service")
+md5sums=('9ef6c5203e098da10aa0d90b344a49da'
'4294f34a8a4644c28788b997dcb4ba22')
+
package() {
cd "$srcdir/diamond-${pkgver}"
install -D -m644 "$srcdir/diamond.service" "$pkgdir/usr/lib/systemd/system/diamond.service"
python2 setup.py install --root="$pkgdir/" --optimize=1
rm "$pkgdir/etc/diamond/diamond.conf.example.windows"
- rm "$pkgdir/etc/diamond/collectors/"*
- rm "$pkgdir/etc/diamond/handlers/"*
+ rm -rf "$pkgdir/etc/diamond/collectors"
+ rm -rf "$pkgdir/etc/diamond/handlers"
+ rm -rf "$pkgdir/usr/share/diamond/user_scripts"
mv "$pkgdir/etc/diamond/diamond.conf.example" "$pkgdir/etc/diamond/diamond.conf"
- mkdir -p "$pkgdir/var/log/diamond" "$pkgdir/etc/diamond/collectors"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}
+