summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2020-04-23 18:11:10 +0200
committerJonne Haß2020-04-23 18:11:10 +0200
commita8d97e6317de4b7c7554ef2b4cfe5b507312d896 (patch)
treeffcf6a4341e384383619eb00d58630834dd6dac8 /PKGBUILD
parent11576ffd9557b1ed8897e96a4bc444e43b6c05e5 (diff)
downloadaur-a8d97e6317de4b7c7554ef2b4cfe5b507312d896.tar.gz
diaspora: use Ruby 2.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f55ba1520cc4..b6864c38cecf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname='diaspora-mysql'
pkgver=0.7.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="A distributed privacy aware social network (MySQL)"
arch=('i686' 'x86_64')
url="https://diasporafoundation.org"
license=('AGPL3')
-depends=('ruby2.4' 'ruby2.4-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'libmariadbclient')
+depends=('ruby2.5' 'ruby2.5-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'libmariadbclient')
optdepends=('jemalloc: lower memory consumption' 'mariadb: Database server')
makedepends=('nodejs' )
conflicts=('diaspora-postgresql' 'diaspora-mysql-git' 'diaspora-postgresql-git')
@@ -45,9 +45,10 @@ _reset_ruby() {
}
build() {
- _bundle=bundle-2.4
- _ruby=ruby-2.4
- _rake=rake-2.4
+ _bundle=bundle-2.5
+ _ruby=ruby-2.5
+ _rake=rake-2.5
+ _gem=gem-2.5
_builddir=$srcdir/build
_reset_ruby
@@ -61,6 +62,8 @@ build() {
msg "Bundle dependencies"
echo "gem: --no-rdoc --no-ri --no-user-install" > $_builddir/.gemrc
+ export GEM_HOME="$_builddir/vendor/bundle"
+ HOME=$_builddir $_gem install bundler -v 1.17.3
HOME=$_builddir $_bundle config --local path vendor/bundle
HOME=$_builddir $_bundle config --local frozen 1
HOME=$_builddir $_bundle config --local disable_shared_gems true
@@ -90,8 +93,8 @@ build() {
}
package() {
- _bundle=bundle-2.4
- _ruby=ruby-2.4
+ _bundle=bundle-2.5
+ _ruby=ruby-2.5
_builddir=$srcdir/build
msg "Copy contents to package directory"