summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2019-02-13 19:28:36 +0100
committerJonne Haß2019-02-13 19:28:36 +0100
commitc75ae80deae221fbcdb4c628ccd395447acc1159 (patch)
treea62414fad4971488db4982525167fe8fe900739b /PKGBUILD
parente717b036ac42e60618e99c070e92244a8620d9f5 (diff)
downloadaur-c75ae80deae221fbcdb4c628ccd395447acc1159.tar.gz
diaspora: update to ruby2.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 083fdd78191c..b4365222a84b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname='diaspora-mysql'
pkgver=0.7.9.0
-pkgrel=5
+pkgrel=6
pkgdesc="A distributed privacy aware social network (MySQL)"
arch=('i686' 'x86_64')
url="https://diasporafoundation.org"
license=('AGPL3')
-depends=('ruby2.3' 'ruby2.3-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'libmariadbclient')
+depends=('ruby2.4' 'ruby2.4-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'libmariadbclient')
optdepends=('jemalloc: lower memory consumption' 'mariadb: Database server')
-makedepends=('nodejs')
+makedepends=('nodejs' )
conflicts=('diaspora-postgresql' 'diaspora-mysql-git' 'diaspora-postgresql-git')
options=(!strip)
backup=("etc/webapps/diaspora/diaspora.yml"
@@ -45,9 +45,9 @@ _reset_ruby() {
}
build() {
- _bundle=bundle-2.3
- _ruby=ruby-2.3
- _rake=rake-2.3
+ _bundle=bundle-2.4
+ _ruby=ruby-2.4
+ _rake=rake-2.4
_builddir=$srcdir/build
_reset_ruby
@@ -90,8 +90,8 @@ build() {
}
package() {
- _bundle=bundle-2.3
- _ruby=ruby-2.3
+ _bundle=bundle-2.4
+ _ruby=ruby-2.4
_builddir=$srcdir/build
msg "Copy contents to package directory"