summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2020-04-23 18:11:10 +0200
committerJonne Haß2020-04-23 18:11:10 +0200
commit08a73d11520392fb882e3d1c8ebbdfd4b636c0fb (patch)
treef8d3981d6020117bf83f7d74cb93556de4e1480e /PKGBUILD
parentfb9ff60fbfd3b0e8e9f5d24cc50107034aa801ba (diff)
downloadaur-08a73d11520392fb882e3d1c8ebbdfd4b636c0fb.tar.gz
diaspora: use Ruby 2.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ad5854aec10..594721a22c45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname='diaspora-postgresql'
pkgver=0.7.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="A distributed privacy aware social network (PostgreSQL)"
arch=('i686' 'x86_64')
url="https://diasporafoundation.org"
license=('AGPL3')
-depends=('ruby2.4' 'ruby2.4-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'postgresql-libs')
+depends=('ruby2.5' 'ruby2.5-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'postgresql-libs')
optdepends=('jemalloc: lower memory consumption' 'postgresql: Database server')
makedepends=('nodejs' )
conflicts=('diaspora-mysql' 'diaspora-mysql-git' 'diaspora-postgresql-git')
@@ -45,9 +45,10 @@ _reset_ruby() {
}
build() {
- _bundle=bundle-2.4
- _ruby=ruby-2.4
- _rake=rake-2.4
+ _bundle=bundle-2.5
+ _ruby=ruby-2.5
+ _rake=rake-2.5
+ _gem=gem-2.5
_builddir=$srcdir/build
_reset_ruby
@@ -61,6 +62,8 @@ build() {
msg "Bundle dependencies"
echo "gem: --no-rdoc --no-ri --no-user-install" > $_builddir/.gemrc
+ export GEM_HOME="$_builddir/vendor/bundle"
+ HOME=$_builddir $_gem install bundler -v 1.17.3
HOME=$_builddir $_bundle config --local path vendor/bundle
HOME=$_builddir $_bundle config --local frozen 1
HOME=$_builddir $_bundle config --local disable_shared_gems true
@@ -90,8 +93,8 @@ build() {
}
package() {
- _bundle=bundle-2.4
- _ruby=ruby-2.4
+ _bundle=bundle-2.5
+ _ruby=ruby-2.5
_builddir=$srcdir/build
msg "Copy contents to package directory"