summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-07-10 23:18:42 +0800
committerzxp198210052023-07-10 23:18:42 +0800
commitfc738255f5500858066617b6a9a40ecdf346a4eb (patch)
tree7ce6c930641df21ff143c4702f0b1f2bff865eee /PKGBUILD
parent0ab15a87461ac377bdafefaaa1d11cd0a8a1bbd1 (diff)
downloadaur-fc738255f5500858066617b6a9a40ecdf346a4eb.tar.gz
update to 2.3.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3dd4492dec3..52b58f8c2609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=dicionario.js-bin
-pkgver=2.3.3
+pkgver=2.3.5
pkgrel=1
pkgdesc="Simple dictionary in which you record your own words."
arch=('x86_64')
url="https://github.com/ArthurLobopro/dicionario.js"
license=('MIT')
conflicts=("${pkgname%-bin}" "${pkgname%-ng-bin}")
-depends=('nss' 'nodejs' 'nspr' 'gtk3' 'glibc' 'alsa-lib' 'libxcomposite' 'mesa' 'libxrandr' 'cairo' 'libxcb' 'at-spi2-core' \
- 'pango' 'libxext' 'gcc-libs' 'libx11' 'libxfixes' 'libxkbcommon' 'glib2' 'libxdamage' 'libdrm' 'dbus' 'libcups' 'expat')
+depends=('electron')
+makedepends=('asar')
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
- "LICENSE::https://raw.githubusercontent.com/ArthurLobopro/dicionario.js/main/LICENSE")
-sha256sums=('d495f71d2019c7e44c8fa16b64d1cb9dfbae04411fc5c86ca4eed491a183351a'
- 'c898d2875697b8ed803b6f18c641a194614b29c26c638eb8135398bc80255e26')
-
+ "${pkgname%-bin}.sh")
+sha256sums=('7d3e23d42f9b42c6e7329b147a3f21c71424fd5a0bdef5ceac94400b38beef5a'
+ '1c0ac994b8c697d90ad4540abb51a4aa2ae17e1027e08a4554c10be4b6cee9ff')
package() {
- bsdtar -xf "${srcdir}/data.tar.zst" -C "${pkgdir}"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- chmod 0755 "${pkgdir}/usr/lib/${pkgname%-bin}/chrome-sandbox"
+ bsdtar -xf "${srcdir}/data.tar.zst"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ asar pack "${srcdir}/usr/lib/${pkgname%-bin}/resources/app" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/usr/share/doc/${pkgname%-bin}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/usr/share/pixmaps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ sed "s|dicionario.js %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file