summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEinhard Leichtfuß2018-03-31 22:30:22 +0200
committerEinhard Leichtfuß2018-03-31 22:34:42 +0200
commit71afe32d44b5b551d946345590f6be636a05dc72 (patch)
tree49f0cec663e1ea5bffc4803fa12fbfa6de22df9a /PKGBUILD
parent3d31696affd9da4f90bd430be78f3799e2b23751 (diff)
downloadaur-71afe32d44b5b551d946345590f6be636a05dc72.tar.gz
Use sources instead of binaries
Binary packages are now to be found as dict-freedict-*-bin. Also, update to version 0.1.6. Furthermore, replace `cp' by `install' and thereby remove the need for explicitly creating the directory to copy the docs in, which might have been pointless in the case of no such file to be copied existing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50f88b8cd1ba..7cd838540e6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,35 @@
# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
-# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info
_lang=eng-fra
pkgname=dict-freedict-${_lang}
-pkgver=0.1.5
+pkgver=0.1.6
pkgrel=1
pkgdesc="English -> French dictionary for dictd et al. from Freedict.org"
arch=('any')
url="http://www.freedict.org/"
license=('GPL')
optdepends=('dictd: dict client and server')
-install=$pkgname.install
-source=("https://sourceforge.net/projects/freedict/files/${_lang}/$pkgver/freedict-${_lang}-$pkgver.tar.bz2")
-sha512sums=('f72eb5da576a3c8d459f2d39ed4adfa9442442293997319ce4558ad2cc6d2e4428d2b84567163961b338724990732dd98f6094768928c43da483f74183c7c99b')
+makedepends=('dictd' 'freedict-tools')
+install=${pkgname}.install
+source=("https://sourceforge.net/projects/freedict/files/${_lang}/${pkgver}/freedict-${_lang}-${pkgver}.src.tar.xz")
+sha512sums=('3ab092e1e5ded48e4bc066c0a8bb221c17904cdc0c30ead4f4b09c6b49cb8af39f2384131fe54055e59c4ceba875df414b255d6b80a2e5ab83bd72b319d91391')
+
+build()
+{
+ cd $_lang
+ make FREEDICT_TOOLS=/usr/lib/freedict-tools build-dictd
+}
package()
{
- mkdir -p "$pkgdir/usr/share/dictd"
- cp ${_lang}/${_lang}.{dict.dz,index} "$pkgdir/usr/share/dictd/"
+ install -m 755 -d "${pkgdir}/usr/share/dictd"
+ install -m 644 -t "${pkgdir}/usr/share/dictd/" \
+ ${_lang}/build/dictd/${_lang}.{dict.dz,index}
+
+ for file in ${_lang}/{AUTHORS,README,NEWS,ChangeLog}
+ do
+ if test -f ${file}
+ then
+ install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" ${file}
+ fi
+ done
}