summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEinhard Leichtfuß2018-03-31 22:31:40 +0200
committerEinhard Leichtfuß2018-03-31 22:34:51 +0200
commit650c435ec7aba6f9187536b7d0d230be84956b71 (patch)
tree0b09ce2fcec157b6a61d415eba74e6d895170e18 /PKGBUILD
parent7f71299c3f93d8e37ed379b5418d044de83dc62f (diff)
downloadaur-650c435ec7aba6f9187536b7d0d230be84956b71.tar.gz
Use sources instead of binaries
Binary packages are now to be found as dict-freedict-*-bin. Also, update to version 0.3. Furthermore, replace `cp' by `install' and thereby remove the need for explicitly creating the directory to copy the docs in, which might have been pointless in the case of no such file to be copied existing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 23 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc83ea193604..ced0895522df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,35 @@
# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
_lang=spa-eng
pkgname=dict-freedict-${_lang}
-pkgver=0.2
-pkgrel=6
+pkgver=0.3
+pkgrel=1
pkgdesc="Spanish -> English dictionary for dictd et al. from Freedict.org"
arch=('any')
url="http://www.freedict.org/"
license=('GPL')
optdepends=('dictd: dict client and server')
-install=$pkgname.install
-source=("https://sourceforge.net/projects/freedict/files/${_lang}/$pkgver/freedict-${_lang}-$pkgver.tar.bz2")
-md5sums=('9611215259c816cfb25d30c5becf8c96')
+makedepends=('dictd' 'freedict-tools')
+install=${pkgname}.install
+source=("https://sourceforge.net/projects/freedict/files/${_lang}/${pkgver}/freedict-${_lang}-${pkgver}.src.tar.xz")
+sha512sums=('d9d92d238b0c849a424ff185187eae39fca6b5fe0be41ce7f77153df154da4b2ac765511b03da2bb418c087ac27d045d536aa755214b4c7161ea30046856a708')
+
+build()
+{
+ cd $_lang
+ make FREEDICT_TOOLS=/usr/lib/freedict-tools build-dictd
+}
package()
{
- mkdir -p "$pkgdir/usr/share/dictd"
- cp ${_lang}/${_lang}.{dict.dz,index} "$pkgdir/usr/share/dictd/"
+ install -m 755 -d "${pkgdir}/usr/share/dictd"
+ install -m 644 -t "${pkgdir}/usr/share/dictd/" \
+ ${_lang}/build/dictd/${_lang}.{dict.dz,index}
+
+ for file in ${_lang}/{AUTHORS,README,NEWS,ChangeLog}
+ do
+ if test -f ${file}
+ then
+ install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" ${file}
+ fi
+ done
}