summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEinhard Leichtfuß2021-07-02 12:33:14 +0200
committerEinhard Leichtfuß2021-07-02 12:40:05 +0200
commit175fc7ffe75d8ba638ed8c5e883a5a955ad36ac2 (patch)
treec5b6e1d9dc1c805c279178285125c7bdcc422b65 /PKGBUILD
parent33af58e0f3dcdfbbd78e9c5d4535fc6fba65b8af (diff)
downloadaur-175fc7ffe75d8ba638ed8c5e883a5a955ad36ac2.tar.gz
Update to version 0.53
This version adopted most of the non dict-specific modifications expressed by `fixes.sed'. This file has could thus have been notably reduced in size. Other changes here: * Use autotools. * fixes.sed * No longer delete lines "This line is printed in <FONT>." * One newfound spelling mistake fixed. * One alleged fix corrected. * Do no longer use `--with-local-libmaa' - failed to build. * Add pronounc.txt to documentation. * Quote everything containing a variable, just to be safe.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 30 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c5d50b40c2a..c6a54fc37a0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,77 +2,89 @@
# Contributor: Tai Chi Minh Ralph Eastwood <tcmreastwood@gmail.com>
pkgname=dict-gcide
_major_debver=0.48
-_debver=${_major_debver}.5
-pkgver=0.52
-pkgrel=2
+_debver="${_major_debver}.5+nmu1"
+pkgver=0.53
+pkgrel=1
pkgdesc="GNU version of the Collaborative International Dictionary of English for dictd et al."
arch=('any')
url="http://gcide.gnu.org.ua/"
license=('GPL3')
optdepends=('dictd: dict client and server')
-makedepends=('dictd' 'sed')
+makedepends=('dictd' 'sed' 'libmaa')
provides=('dictd-gcide')
conflicts=('dictd-gcide')
-install=${pkgname}.install
+install="${pkgname}.install"
source=('fixes.sed'
'post_webfilter.sed'
'check.sed'
- "http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${_debver}.tar.xz"
- "ftp://ftp.gnu.org/gnu/gcide/gcide-${pkgver}.tar.xz"{,.sig})
-sha512sums=('6fc2caf86d96ac9a14f2676ca4455afe987f37933c03ac672b27cf2de7a4fc893457c97c7fa17dc280debfb4e1a3ab4adc5f7c68ee445605dc3c22665d32a445'
+ "https://deb.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${_debver}.tar.xz"
+ "https://ftp.gnu.org/gnu/gcide/gcide-${pkgver}.tar.xz"{,.sig})
+sha512sums=('912e3a6ba1db08a75df4cd7aeaa8b6d4acf02a6e7982a992f0023d979251b0dc46877ef76e2d16a9fc5921e35debaeb339cde19b033d94f9797325320c3fb43b'
'e7c6766b51ef92c4d8669394b6a71f8c4d7249ac63a1eb940f0a3017cb5ff6841f0f4bce7a60ffbcf180801d92b068db6ca46afd1dceac06a9c37c59dcddbfb3'
'1304bdce3776355fcd7827cebbf670ae34377bda78b04bf271ba10a25d92e33f6ec69644e168c30a6ec47808ebacc461de47d9494a5a2a5894d58c21be045973'
- 'a10d46947c7d8b7050c44a12cfb38ed374e971063805e69897652cd8993dc5cf0ecc4d9a12680a8ced30d110d20bc84def75bd587166aa2cfa78529b9397aafe'
- '260e4e7bb30ac857255b9a1f696b18b77bbae06574bb0f0cc35b38be7399bf497d3c561ab0d4a4b7e8fc3127c6bf72efde8e1d4a28fa428f82178d0972f704b3'
+ '775775fbcf49f6f9e29ad60919692f02b920efe710bc311674cc37f045b69ef9ee68e2fe4045a39a90485a0661581267ce13590f893eb3a896c947d5b760638e'
+ '0eb641cdc8186757bb7e221753c9a42f28ead25b72b18cacebf2326ee239c0e5ab2d41b61928371168ff2c8a298aeaa93d50656d8165ae155699c1d359e4918f'
'SKIP')
validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732')
+
prepare()
{
+ cd "${pkgname}-${_debver}"
+
sed -Ei \
"s/\"(The Collaborative International Dictionary of English) v.${_major_debver}\"/\"\\1 v.${pkgver}\"/" \
- "${pkgname}-${_debver}/scan.l"
+ scan.l
+
+ # Remove autogenerated autotools files.
+ rm config.guess config.h.in config.sub configure install-sh
}
+
build()
{
cd ${pkgname}-${_debver}
- CPPFLAGS="-D_FORTIFY_SOURCE=0" ./configure --with-local-libmaa
+ autoreconf -fis
+ ./configure
make -j1
# Do the conversion explicitly, instead of `make db', to account for all
# the differences to the original build process.
# LANG=C is required so that the index file is properly sorted.
- ../fixes.sed ../gcide-${pkgver}/CIDE.? \
+ ../fixes.sed "../gcide-${pkgver}"/CIDE.? \
| sed -f debian/sedfile \
| ./webfilter \
| ../post_webfilter.sed \
| tee pre_webfmt.data \
| LANG=C ./webfmt -c
+ # `dictzip -v' neclects to print a final newline.
dictzip -v gcide.dict
+ printf '\n'
}
+
check()
{
- errors="$(./check.sed < ${pkgname}-${_debver}/pre_webfmt.data)"
+ errors="$(./check.sed < "${pkgname}-${_debver}/pre_webfmt.data")"
if test -n "$errors"
then
- echo "Errors found:"
- echo "$errors"
+ printf 'Errors found:\n'
+ printf '%s\n' "$errors"
return 1
fi
}
+
package()
{
install -m 0755 -d "${pkgdir}/usr/share/dictd"
install -m 0644 -t "${pkgdir}/usr/share/dictd/" \
- ${pkgname}-${_debver}/gcide.{dict.dz,index}
+ "${pkgname}-${_debver}"/gcide.{dict.dz,index}
install -m 0755 -d "${pkgdir}/usr/share/doc/dict-gcide"
install -m 0644 -t "${pkgdir}/usr/share/doc/dict-gcide/" \
- gcide-${pkgver}/{README,INFO}
+ "gcide-${pkgver}"/{README,INFO,pronunc.txt}
}