summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrespiranto2015-08-23 21:27:12 +0200
committerrespiranto2015-08-23 21:27:12 +0200
commitefc8365dfa4b22d819e924d92b97695589cd2249 (patch)
treee753c6a86f56d60529b6e40ab1099346a6e19ca0 /PKGBUILD
downloadaur-efc8365dfa4b22d819e924d92b97695589cd2249.tar.gz
Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4746f71efffa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: respiranto <respiranto@icloud.com>
+# Contributor: Tai Chi Minh Ralph Eastwood <tcmreastwood@gmail.com>
+pkgname=dict-gcide
+pkgver=0.48.1
+pkgrel=1
+pkgdesc="GNU version of the Collaborative International Dictionary of English in dict format"
+arch=('any')
+url="http://www.dict.org/"
+license=('GPL')
+optdepends=('dictd: dict client and server')
+makedepends=('dictd')
+replaces=('dictd-gcide')
+install=$pkgname.install
+source=("ftp://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.gz")
+md5sums=('44fa2d940c58e65635357fee76772a35')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CPPFLAGS="-D_FORTIFY_SOURCE=0"
+ ./configure --with-local-libmaa --prefix=/usr
+ make
+ mkdir -p "$srcdir/final_data"
+ make dictdir="$srcdir/final_data" install
+ # fix wrong order:
+ LANG=C sort --dictionary-order --ignore-case -o "$srcdir/final_data"/gcide.index{,}
+}
+
+package()
+{
+ mkdir -p "$pkgdir/usr/share/dictd"
+ mv "$srcdir/final_data"/* "$pkgdir/usr/share/dictd/"
+}