summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-29 04:38:19 +0200
committerChristopher Arndt2022-09-29 04:38:19 +0200
commit4ae8de3467769b5fe3748db2b58e990695c88cc8 (patch)
treee80536958bc0b2e1e8a9be252f46a1b35dbdbb20 /PKGBUILD
downloadaur-4ae8de3467769b5fe3748db2b58e990695c88cc8.tar.gz
Add new package die-plugins
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c7f062aa55d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name=DIE-Plugins
+pkgname=${_name,,}
+pkgdesc="DISTRHO Imported Effect Plugins, Ardour's plugins without Ardour"
+pkgver=1.1
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/DISTRHO/$_name"
+license=(GPL2)
+groups=(lv2-plugins pro-audio)
+depends=(glibc gcc-libs)
+makedepends=(git glib2 libsndfile lv2)
+optdepends=('lv2-host: for loading LV2 plugins')
+source=("$_name-$pkgver.tar.gz::https://github.com/DISTRHO/$_name/archive/refs/tags/v$pkgver.tar.gz"
+ 'die-plugins-maintainer-mod-brand.patch::https://github.com/DISTRHO/DIE-Plugins/pull/1.diff')
+sha256sums=('bef945fd7534a4bdaacd6bc57548ac3a9da97446c2b2e5a56b27ebfa2092a49a'
+ 'ee961e520e0bf0d98899fcc284cf7d4dbad6b59d0d98ed1ab1d4411889ead12a')
+
+
+prepare() {
+ cd $_name-$pkgver
+ patch -p1 -N -r - -i "$srcdir"/die-plugins-maintainer-mod-brand.patch
+}
+
+build() {
+ cd $_name-$pkgver
+ make
+}
+
+package() {
+ depends+=(libglib-2.0.so libsndfile.so)
+ cd $_name-$pkgver
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ chmod +x "$pkgdir"/usr/lib/lv2/*.lv2/*.so
+}