summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2020-08-30 16:25:54 +0200
committerPhilipp A2020-08-30 16:25:54 +0200
commit2bf08a8fcca60b302903232a29260fba013246e6 (patch)
tree60675f994c67b28cc331d19918cd30c065d64325 /PKGBUILD
parent3f928699c4543c022ed47fcd266816b6419e6959 (diff)
downloadaur-2bf08a8fcca60b302903232a29260fba013246e6.tar.gz
5.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36e4fdfcdd8c..e5429d4c0ca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=digestif
pkgver=0.3
-pkgrel=2
+pkgrel=3
arch=(any)
license=(MIT)
url="https://github.com/astoff/$pkgname"
@@ -18,8 +18,9 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
+ local luaver=$(lua -e 'print(_VERSION)' | cut -d' ' -f2)
luarocks install --tree="$pkgdir/usr/" --deps-mode=none "$pkgname-$pkgver-1.rockspec"
- sed -i "s|'.*?/bin/$pkgname'|'/usr/lib/luarocks/rocks-5.3/digestif/$pkgdir-1/$pkgname'|" "$pkgdir/usr/bin/digestif"
+ sed -i "s|'.*?/bin/$pkgname'|'/usr/lib/luarocks/rocks-$luaver/digestif/$pkgdir-1/$pkgname'|" "$pkgdir/usr/bin/digestif"
# remove luarocks-created root manifest
- rm "$pkgdir/usr/lib/luarocks/rocks-5.3/manifest"
+ rm "$pkgdir/usr/lib/luarocks/rocks-$luaver/manifest"
}