summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcyrozap2020-08-02 14:40:10 -0500
committercyrozap2020-08-02 14:55:10 -0500
commit6bd03123972436b156c4fccda182c7038886028c (patch)
treebcf95ae364f4b9123a2695ce4c3634b233a5e507 /PKGBUILD
parent0d7d189aa48dc559e334058f36f3ba98d9f678a7 (diff)
downloadaur-6bd03123972436b156c4fccda182c7038886028c.tar.gz
Update to version 2.20.2 for i686 and x86_64
Unfortunately, Digilent has not yet released the new version of the runtime for ARM, so in the meantime I've manually set the URL for the ARM version of this package to that of the previous version (2.20.1).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5622e4e1b9a..0989091076d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=digilent.adept.runtime
-pkgver=2.20.1
+pkgver=2.20.2
pkgrel=1
pkgdesc="The Adept Runtime consists of the shared libraries, firmware images, and configuration files necessary to communicate with Digilent's devices."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -10,14 +10,17 @@ license=('custom')
depends=('libusb')
options=('!strip')
backup=('etc/digilent-adept.conf' 'etc/ld.so.conf.d/digilent-adept-libraries.conf' 'etc/udev/rules.d/52-digilent-usb.rules')
-source_armv6h=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-armhf.deb")
+#source_armv6h=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-armhf.deb")
+# Unfortunately, Digilent has not yet released the new version of the runtime for ARM, so in the meantime I've
+# manually set the URL for the ARM version of this package.
+source_armv6h=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/2.20.1/${pkgname}_2.20.1-armhf.deb")
source_armv7h=($source_armv6h)
source_i686=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-i386.deb")
source_x86_64=("https://digilent.s3.amazonaws.com/Software/Adept2+Runtime/${pkgver}/${pkgname}_${pkgver}-amd64.deb")
sha256sums_armv6h=('941cd3c9f8b4e223da7ed737ca5592f3ac7eb5aa63adf57739d91c1f44f5691a')
sha256sums_armv7h=($sha256sums_armv6h)
-sha256sums_i686=('66814836b39bfb79c273506c2b7ff0b750ffbec868030b8fac74b4c19c5d9a44')
-sha256sums_x86_64=('fd6c50d1522fc56b6f1ae21024b460e353ee64e26e48b44f4399e82c09dfe270')
+sha256sums_i686=('84e0d3ad35284019f7fa56af83e7d36ac670df1407cb2b898907b16a9089f9fa')
+sha256sums_x86_64=('9bdb1c7b3f2565a49f899ab6fd1ab4f17db905e426e422fd841ea949b6ee46ee')
package() {
# Extract