summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2016-01-08 13:06:10 -0800
committerShadowKyogre2016-01-08 13:12:50 -0800
commit629997f437ce3a9cb699089d0c4796ff006e08f4 (patch)
treea00c34d1fe04abaac2cc214f9aa23ec8911a9afb /PKGBUILD
downloadaur-629997f437ce3a9cb699089d0c4796ff006e08f4.tar.gz
Package dilay for the AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba37e9124c02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=dilay
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A 3D sculpting application that provides an intuitive workflow using a number of powerful modeling tool"
+arch=('i686' 'x86_64')
+url="http://abau.org/dilay/index.html"
+license=('GPL')
+depends=('glm' 'qt5-base')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/abau/dilay/archive/${pkgver}.tar.gz")
+
+prepare() {
+ gendesk -f -n --pkgname "$dilay" --pkgdesc "$pkgdesc"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake-qt5 -r PREFIX="${pkgdir}/usr"
+ make release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 logoBg.svg "$pkgdir/usr/share/pixmaps/$pkgname.svg"
+}
+
+sha1sums=('5c4af7c6974e7c8a777ce45cefa9f5b43a3b4be2')