summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormuzhed2018-04-05 00:19:34 +0800
committermuzhed2018-04-05 00:19:34 +0800
commitfd2689ff36249d447864471e9ee37ae6ffe43ea7 (patch)
treeb2dafb33c35d3e5469014067f255b7962a96fe81 /PKGBUILD
parent17ec5389502484e58fb9d6436bd3990969bf3dec (diff)
downloadaur-fd2689ff36249d447864471e9ee37ae6ffe43ea7.tar.gz
update to din 32
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 189b25e62258..ad3bd6a7832c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: muzhed <chustokes@126.com>
pkgname=din
-pkgver=30
+pkgver=32
pkgrel=1
pkgdesc="A sound synthesizer and musical instrument."
arch=("i686" "x86_64")
@@ -11,24 +11,17 @@ depends=('jack' 'libgl' 'sdl' 'tcl')
makedepends=('boost')
source=("https://archive.org/download/dinisnoise_source_code/$pkgname-$pkgver.tar.gz"
din.png
- din.desktop
- path.patch)
-md5sums=('45c5854b2b95d4c67f6771703cb2f155'
+ din.desktop)
+md5sums=('e80b3c11f265d4f47055213e3821a1aa'
'50ca4dc107eaa0d5b6a1efe21c469bd7'
- 'e38840354b0f197079e6bbeda03c8613'
- 'ceb6b3e310e1244d09be00113f459acf')
-
-prepare() {
- cd "$srcdir"/"$pkgname-$pkgver"/src
- patch -p0 -i "$srcdir"/path.patch
-}
+ 'e38840354b0f197079e6bbeda03c8613')
build() {
cd "$srcdir"/"$pkgname-$pkgver"
autoreconf -fvi
# use alsa instead of jack
- # ./configure CXXFLAGS="-O3 -D__UNIX_ALSA__" CFLAGS=-O3
+ # ./configure --prefix=/usr CXXFLAGS="-O3 -D__UNIX_ALSA__" CFLAGS=-O3
./configure --prefix=/usr CXXFLAGS="-O3 -D__UNIX_JACK__" CFLAGS=-O3
make
}