summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2023-02-06 22:33:47 -0600
committerLuis Martinez2023-02-06 22:33:47 -0600
commitc2aba79fafb130aa468b6177a36dc4fd14580fdc (patch)
tree8646a8b24dbaf636b071153f4052d7b8ada3f895 /PKGBUILD
parent36567b62d16297b676d3d7527ff131f470654fc2 (diff)
downloadaur-diodon.tar.gz
packaging cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b779d7de19c9..6fd741367696 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,13 @@
pkgname=diodon
pkgver=1.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="GTK+ clipboard manager"
arch=('x86_64')
license=('GPL')
url="https://launchpad.net/diodon"
-depends=(
- 'gobject-introspection'
- 'libappindicator-gtk3'
- 'libayatana-appindicator'
- 'libpeas'
- 'xorg-server-xvfb'
- 'zeitgeist')
-makedepends=('cmake' 'meson' 'vala')
+depends=('gtk3' 'libayatana-appindicator' 'libpeas' 'libxtst' 'zeitgeist')
+makedepends=('gobject-introspection' 'meson' 'vala' 'xorg-server-xvfb')
provides=('libdiodon.so')
source=("$pkgname-$pkgver.tar.xz::$url/trunk/$pkgver/+download/$pkgname-$pkgver.tar.xz")
sha256sums=('5f25ce431ef083afdefa50103f22d3e16d47ec753ed2b29867a04e25146e17a1')
@@ -26,9 +20,9 @@ build() {
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {
- meson install -C build --destdir="$pkgdir/"
+ meson install -C build --destdir "$pkgdir"
}