summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Golatofski2020-02-13 21:35:41 +0100
committerFelix Golatofski2020-02-13 21:35:41 +0100
commit12d82d0c724fb5b35c98bfc0b4c5e5d3ff5d152f (patch)
tree085133af3adc1be133fa3622635d8ef8d605cead /PKGBUILD
parenta86bc790ca26437075283369ebc0aa2b9b9fa0a9 (diff)
downloadaur-12d82d0c724fb5b35c98bfc0b4c5e5d3ff5d152f.tar.gz
Updated source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a75b6886c948..07a04aeff7e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,18 @@
pkgname=directfb
pkgver=1.7.7
-pkgrel=2
+pkgrel=3
pkgdesc="A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device"
arch=('i686' 'x86_64')
url="http://www.directfb.org"
license=('LGPL')
depends=('gcc-libs' 'libjpeg' 'sdl' 'libpng' 'freetype2' 'libdrm' 'libgl' 'mesa')
-#source=(http://www.directfb.org/downloads/Core/DirectFB-${pkgver%.*}/DirectFB-${pkgver}.tar.gz)
-source=(http://sources.webos-ports.org/DirectFB-$pkgver.tar.gz)
-sha1sums=('205d824906906303db9b096cc2d3bea0662e8860')
+source=(https://github.com/deniskropp/DirectFB/archive/DIRECTFB_1_7_7.tar.gz)
+sha512sums=('4b4c800e3fa18a02aba6cd2224b57fd9522b024a5b90a5f69676d73254875513822634d039f307a2e5334bbb9f905a8e7d8d6bd388fcbc94580a35d652965f32')
build() {
- cd DirectFB-${pkgver}
+ cd $srcdir/DirectFB-DIRECTFB_1_7_7/
+ ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --enable-static \
--enable-zlib --enable-x11 --enable-sdl --disable-vnc --disable-osx \
--enable-video4linux2 --enable-voodoo \
@@ -25,6 +25,6 @@ build() {
}
package() {
- cd DirectFB-${pkgver}
+ cd $srcdir/DirectFB-DIRECTFB_1_7_7/
make DESTDIR="${pkgdir}" install
}