summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormorganamilo2019-04-19 01:56:23 +0100
committermorganamilo2019-04-19 01:56:23 +0100
commit497a49a06c2df212bc6a39a324e81f04c1410f42 (patch)
tree9d0fc089fa51dc1b3d80e000a61498ee98e3ced2 /PKGBUILD
parent30b63ea0158e8eff6edb92e549b9c049b0e50abe (diff)
downloadaur-497a49a06c2df212bc6a39a324e81f04c1410f42.tar.gz
Fixup pkgbuild
Remove defunct files Remove install Fix perms on .desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 329785eaf580..f20e91cf59a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=discord
pkgver=0.0.9
-pkgrel=1
+pkgrel=2
pkgdesc="All-in-one voice and text chat for gamers that's free and secure."
arch=('x86_64')
url='https://discordapp.com/'
@@ -18,14 +18,11 @@ optdepends=(
'noto-fonts-cjk: Font for special characters such as /shrug face.'
)
-install="Discord.install"
source=(LICENSE
"https://dl.discordapp.net/apps/linux/${pkgver}/${pkgname}-${pkgver}.tar.gz")
md5sums=('26b3229c74488c64d94798e48bc49fcd'
'3fc3bd78302f4a27dc730e82089b99d9')
-#This is always latest build, right now I do not know of a version param.
-
package() {
# Install the main files.
install -d "${pkgdir}/opt/${pkgname}"
@@ -35,19 +32,17 @@ package() {
chmod 755 "${pkgdir}/opt/${pkgname}/Discord"
# Desktop Entry
- install -d "${pkgdir}/usr/share/applications"
- install "${pkgdir}/opt/${pkgname}/${pkgname}.desktop" "${pkgdir}/usr/share/applications"
+ install -Dm 644 "${pkgdir}/opt/${pkgname}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
sed -i s%/usr/share%/opt% ${pkgdir}/usr/share/applications/${pkgname}.desktop
# Main binary
- #install "${srcdir}/Discord.sh" "${pkgdir}/usr/bin/discord"
- mkdir -p ${pkgdir}/usr/bin
+ install -d "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/Discord" "${pkgdir}/usr/bin/${pkgname}"
# Create symbolic link to the icon
install -d "${pkgdir}/usr/share/pixmaps"
ln -s "/opt/${pkgname}/discord.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
-
+
# License
install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}