summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCayde Dixon2016-04-15 00:26:24 +1000
committerCayde Dixon2016-04-15 00:52:55 +1000
commit64d0042bd480c7499d296fda578fcdbc7aa6ef34 (patch)
tree931607ab45374cbb586e013bf843e89909efe9f8 /PKGBUILD
parenta1d9063e2caa173d287c88c6b5e028b48774daf9 (diff)
downloadaur-64d0042bd480c7499d296fda578fcdbc7aa6ef34.tar.gz
implement the PULSE_LATENCY_MSEC=30 fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbfe98d1f896..c5af5dcb50d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=discord-canary
pkgver=0.0.1
-pkgrel=4
+pkgrel=5
pkgdesc='Discord Canary linux release'
arch=('x86_64')
url='https://discordapp.com/'
@@ -11,9 +11,9 @@ license=('custom')
depends=('gtk2' 'gconf' 'libnotify')
optdepends=('freetype2-infinality: If you have black screens with emojis install this.')
-source=(DiscordCanary.desktop LICENSE)
+source=(DiscordCanary.desktop LICENSE DiscordCanary.sh)
source_x86_64=("https://storage.googleapis.com/discord-developer/test/discord-canary-${pkgver}.tar.gz")
-sha256sums=('67eb4842aec28f26e894315d46c7250e5958eab7f2f24c1f54db40ec302e41f0' '688f418cd32a682c6d331c211fedd48ff86ee8ba5a7640f589eadb32996af80f')
+sha256sums=('13d122f47be0d659b0630be52d82bbfc838861ce213c1f024ea71445dd2067fe' '688f418cd32a682c6d331c211fedd48ff86ee8ba5a7640f589eadb32996af80f' '912cb31b21023980614437b859bb11f39697108c0e9ca21778f81da8065a0815')
sha256sums_x86_64=('0fb4b64b6119311279ec79b4a11c9f0640553ca437e36302f3b8134d10e375ea')
package() {
@@ -31,7 +31,9 @@ package() {
# Main binary
install -d "${pkgdir}/usr/bin"
- ln -s "/opt/${pkgname}/DiscordCanary" "${pkgdir}/usr/bin/DiscordCanary"
+ #ln -s "/opt/${pkgname}/DiscordCanary" "${pkgdir}/usr/bin/DiscordCanary"
+ #installing from .sh due to how the tar extracts.
+ install "${srcdir}/DiscordCanary.sh" "${pkgdir}/usr/bin/DiscordCanary"
# Create symbolic link to the icon
install -d "${pkgdir}/usr/share/pixmaps"