summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCayde Dixon2016-03-25 17:11:24 +1100
committerCayde Dixon2016-03-25 17:27:00 +1100
commitd28c41e1ce7065a0589ea67b383b64c0d0e66fcf (patch)
tree3e6908d202c9081f7bc54cf5a3c17d3f6b5ab206 /PKGBUILD
downloadaur-d28c41e1ce7065a0589ea67b383b64c0d0e66fcf.tar.gz
Initial commit with DiscordCanary v0.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60aeef3a301a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Cayde Dixon <me@cazzar.net>
+
+pkgname=discord-canary
+pkgver=0.0.0
+pkgrel=1
+pkgdesc='Discord Canary linux release'
+arch=('x86_64')
+url='https://discordapp.com/'
+provides=('discord-canary')
+license=('custom')
+depends=('gtk2' 'gconf')
+optdepends=('freetype2-infinality: If you have black screens with emojis install this.')
+
+source=(DiscordCanary.desktop LICENSE)
+source_x86_64=("https://storage.googleapis.com/discord-developer/test/discord-canary-${pkgver}.tar.gz")
+sha256sums=('851cf241f5f2418a4a5dc533e0060844ee5673f7cac563fd33e2584b09dbe2d0' '688f418cd32a682c6d331c211fedd48ff86ee8ba5a7640f589eadb32996af80f')
+sha256sums_x86_64=('0edc1be19faf2e6401c408b1097901ce582222348f144e38c51749bd38ba3dd6')
+
+package() {
+ # Install the main files.
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/DiscordCanary/." "${pkgdir}/opt/${pkgname}"
+
+ # Exec bit
+ chmod 755 "${pkgdir}/opt/${pkgname}/DiscordCanary"
+
+
+ # Desktop Entry
+ install -d "${pkgdir}/usr/share/applications"
+ install "${srcdir}/DiscordCanary.desktop" "${pkgdir}/usr/share/applications"
+
+ # Main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/DiscordCanary" "${pkgdir}/usr/bin/DiscordCanary"
+
+ # Create symbolic link to the icon
+ install -d "${pkgdir}/usr/share/pixmaps"
+ ln -s "/opt/${pkgname}/discord.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}