summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAtticFinder655362023-11-25 10:54:16 +1100
committerAtticFinder655362023-11-25 10:54:16 +1100
commit4296855512968b26c53baa74ef4207a19b3b72f5 (patch)
treed895a0b355c91417ab0fb9012824863006adf2b1 /PKGBUILD
parent08c1604945afe739082da8e15f6fa14f0036e6c2 (diff)
downloadaur-4296855512968b26c53baa74ef4207a19b3b72f5.tar.gz
Switch to source build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 33 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00bc4fb73fa8..3535ca764398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
-# Maintainer: JianQing Liu <me at pegasis dot site>
-pkgname=discord-chat-exporter-cli
+# Maintainer: AtticFinder65536 <atticfinder -AT- rocklabs -DOT- xyz>
+# Contributor: JianQing Liu <me at pegasis dot site>
+
+# stable release
+
+pkgname="discord-chat-exporter-cli"
+_apkgname="DiscordChatExporter"
pkgver=2.42.3
pkgrel=1
-pkgdesc="Export message history from a Discord channel to a file"
-arch=('any')
-url="https://github.com/Tyrrrz/DiscordChatExporter"
-license=('GPL')
-depends=('dotnet-runtime>=6')
-makedepends=('unzip')
-source=("$pkgname-$pkgver.zip::https://github.com/Tyrrrz/DiscordChatExporter/releases/download/$pkgver/DiscordChatExporter.CLI.zip"
-"discord-chat-exporter-cli")
-noextract=("$pkgname-$pkgver.zip")
-md5sums=('dd950ea5a9990815b048218da7cb6e73'
-'8077678acad67ad31578593deee8bcc6')
-BUILDENV+=('!check')
-
-prepare() {
- cd "$srcdir"
- mkdir -p "$srcdir/unzip"
- cd "$srcdir/unzip"
- unzip -q "$srcdir/$pkgname-$pkgver.zip"
- chmod 666 -R ./*
- rm "$srcdir/$pkgname-$pkgver.zip"
+
+pkgdesc="Exports Discord chat logs to a file"
+url="https://github.com/Tyrrrz/$_apkgname"
+license=(GPL3)
+arch=(any)
+
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
+ "$pkgname"
+)
+b2sums=(
+ 36d031776bece2c9d72cd7d64c955158464faca3fac2b5dd422bbcec7c6f34b6da4cf3cf8fa8ce7cfbbf1880c7df68204e42f5eed52479860eff016ae3107e16
+ 7540fb95f81c1041c87778c590a9438ffb64bf417c3d4d3f1363da5a25898c98f9dcd1209b9237bd595374a33326b7f23043bd6156cc7e14f0bff230ee0f6de6
+)
+
+options=('!strip')
+
+depends=('dotnet-runtime-7.0')
+makedepends=('dotnet-sdk-7.0')
+
+build() {
+ cd "$_apkgname-$pkgver"
+ dotnet publish "$_apkgname.Cli" --configuration "Release"
}
package() {
- cd "$srcdir"
- mkdir -p "$pkgdir/opt/"
- mv "$srcdir/unzip" "$pkgdir/opt/discord-chat-exporter-cli"
- install -m755 discord-chat-exporter-cli "$pkgdir/opt/discord-chat-exporter-cli/"
- mkdir -p "$pkgdir/usr/bin/"
- ln -s "/opt/discord-chat-exporter-cli/discord-chat-exporter-cli" "$pkgdir/usr/bin/discord-chat-exporter-cli"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd "$_apkgname-$pkgver/$_apkgname.Cli/bin/Release/net7.0/publish"
+ find . -type f -exec install -Dm644 "{}" "$pkgdir/usr/lib/$pkgname/{}" \;
}