summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-11-20 10:13:27 +0800
committerzxp198210052023-11-20 10:13:27 +0800
commitdf0ecd14b24001d4348e063d669aa89d9ce4af25 (patch)
treec5057c56389c514ab320da45862a7d207327c82c /PKGBUILD
parentde67120b6632125d9533a73d4c44f47055a2f88b (diff)
downloadaur-df0ecd14b24001d4348e063d669aa89d9ce4af25.tar.gz
update to 1.1.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 24 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b9195b77a20..4e6b301f403a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,42 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=discord-netflix
_pkgname=Discord-Netflix
-pkgver=1.1.11
-pkgrel=2
+pkgver=1.1.12
+pkgrel=1
pkgdesc="An updated and improved version from the original Discord-Netflix from Nirewen."
arch=('any')
url="https://discord.gg/kbf8EjpxbU"
-_githuburl="https://github.com/V0l-D/Discord-Netflix"
+_ghurl="https://github.com/V0l-D/Discord-Netflix"
license=('GPL3')
conflicts=("${pkgname}")
-depends=('bash' 'electron21')
-makedepends=('gendesk' 'nodejs>=7' 'npm' 'python>=3.9.0' 'git')
-source=("${pkgname}-${pkgver}.zip::${_githuburl}/archive/refs/tags/v${pkgver}.zip"
- "${pkgname}.sh")
-sha256sums=('0089ede7b55b408258b63104589717bf73393a6a09e9f85c782377f55ecfe50f'
- 'c0f247e4fede012344c55ccbaad92eea1e2a20c68204368df2692dfcb8a40ba1')
-prepare() {
- gendesk -f -n -q --categories "Utility" --name "${pkgname}" --exec "${pkgname}"
-}
+depends=(
+ 'electron21'
+)
+makedepends=(
+ 'gendesk'
+ 'nodejs>=7'
+ 'npm'
+ 'python>=3.9.0'
+ 'git'
+ 'make'
+ 'gcc'
+)
+source=(
+ "${pkgname}-${pkgver}.zip::${_ghurl}/archive/refs/tags/v${pkgver}.zip"
+ "${pkgname}.sh"
+)
+sha256sums=('c6b771f3c5c7e4553e8ff358072d08a1c176915719c87bf07730a4ae8554bd52'
+ '5674299baf9b5c4d830cb5e360b285e933efe21bb815009009819a38c2915d1c')
build() {
+ gendesk -f -n -q --categories "Utility" --name "${pkgname}" --exec "${pkgname}"
cd "${srcdir}/${_pkgname}-${pkgver}"
npm install
npm run linbuild
}
package() {
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/opt/${pkgname}/resources"
+ install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname}"
+ cp -r "${srcdir}/${_pkgname}-${pkgver}/dist/linux-unpacked/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname}"
install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/assets/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"