summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-06 14:01:45 +0100
committerFelix Golatofski2020-01-06 14:01:45 +0100
commit419840f2416f5639f3d7323133138b4a77ef4a9d (patch)
treea11dfab4a7b508955a6395829f8872e1b60a4b59 /PKGBUILD
parent6591878c3de37d5f6b2f692ca64b62715f7f9252 (diff)
downloadaur-419840f2416f5639f3d7323133138b4a77ef4a9d.tar.gz
Added gem install for bundler to prepare section
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a7f72dd5e60..ba8bcd962dcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=discourse
pkgver=2.3.8
-pkgrel=1
+pkgrel=2
pkgdesc="A simple, flat forum, where replies flow down the page in a line"
arch=('i686' 'x86_64')
url="http://www.discourse.org/"
license=('GPL')
-depends=('ruby>=2.0' 'ruby-bundler>=1.17.3' 'gmp' 'libxml2' 'libxslt' 'openssl'
+depends=('ruby>=2.0' 'ruby-bundler' 'gmp' 'libxml2' 'libxslt' 'openssl'
'krb5' 'libgcrypt' 'libgpg-error' 'postgresql-libs' 'xz' 'zlib')
makedepends=('uglify-js')
optdepends=('apache: a webserver to deploy discourse'
@@ -62,7 +62,8 @@ _systemddir="/usr/lib/systemd/system"
prepare() {
cd "${srcdir}/${pkgname}"
-
+ # Install the appropriate version of bundler
+ gem install bundler -v '1.17.3'
# Patch source files to include a static revision string and remove git repo.
# Including the git repository triples the package size.
_revision=$(git rev-parse HEAD)