summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFedor Piecka2023-06-08 09:56:30 +0200
committerFedor Piecka2023-06-08 09:56:30 +0200
commitf6ba5c5f946a4edb286fe461fab0fa6ceaf0746f (patch)
treec238f9e7100d9e40042ac41ad1fa654ea3b87279 /PKGBUILD
parent5b6d3c350c5ef9e3e27cef39d91377ff6246a210 (diff)
downloadaur-f6ba5c5f946a4edb286fe461fab0fa6ceaf0746f.tar.gz
Upgrade to upstream 2.1.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47edbc96f7c4..743c83d37310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Fedor Piecka <teplavoda at gmail dot com>
pkgname=disig-web-signer
-pkgver=2.0.7
-pkgrel=3
+pkgver=2.1.1
+_upstream_pkgrel=1
+pkgrel=1
pkgdesc="Slovak eID Web Signer by Disig"
arch=('i686' 'x86_64')
license=('custom')
url="https://qesportal.sk/"
-source_i686=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.ubuntu_i386.deb')
-source_x86_64=('https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer.ubuntu_amd64.deb')
-md5sums_i686=('SKIP')
-md5sums_x86_64=('SKIP')
+source_x86_64=("https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer_${pkgver}-${_upstream_pkgrel}.ubuntu_amd64.deb")
+source_i686=("https://download.disigcdn.sk/cdn/products/websigner2/disig-web-signer_${pkgver}-${_upstream_pkgrel}.ubuntu_i386.deb")
+sha256sums_x86_64=('2eebf5eae8d536e6b258245f0581f05d49473b89222215b8e6013341c66b6444')
+sha256sums_i686=('3f6ae031ce3035626e9d8b91f8865f895f4ef1d1b28ad2e1a670ed2c19179846')
options=("!strip")
# Upstream uses Debian architecture naming convention. Let's prepare a variable for that.
@@ -18,16 +19,10 @@ upstream_arch=
[[ "$CARCH" == "x86_64" ]] && upstream_arch="amd64"
[[ "$CARCH" == "i686" ]] && upstream_arch="i386"
-
-pkgver() {
- # Match Debian package version
- ar p ${srcdir}/disig-web-signer.ubuntu_${upstream_arch}.deb control.tar.gz | tar -Oxz ./control | grep ^Version: | cut -f2 -d" " | tr -d '[:space:]' | cut -f1 -d"-"
-}
-
package() {
depends=("glibc" "gcc-libs" "mesa" "qt5-base" "qt5-websockets")
- ar p ${srcdir}/disig-web-signer.ubuntu_${upstream_arch}.deb data.tar.xz | tar -xJ -C "${pkgdir}"
+ ar p "${srcdir}/disig-web-signer_${pkgver}-${_upstream_pkgrel}.ubuntu_${upstream_arch}.deb" data.tar.xz | tar -xJ -C "${pkgdir}"
# Create a native messaging host for Google Chrome browser and Chromium; this is done by a postinst script in upstream deb package
mkdir -p ${pkgdir}/etc/opt/chrome/native-messaging-hosts ${pkgdir}/etc/chromium/native-messaging-hosts