summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreomanis2019-09-24 19:03:31 +0200
committereomanis2019-09-24 19:03:31 +0200
commit0515c2789236d3ed505b1a93cd9192359cf61c57 (patch)
treebba7878df30d4bf0ef48761b2f28cb69286f6dbe /PKGBUILD
parentddefd609bead0a4723c383b02e96dfffef935b70 (diff)
downloadaur-0515c2789236d3ed505b1a93cd9192359cf61c57.tar.gz
Update to version 0.2.0
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f8153f1964e..e180154fa060 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: eomanis at web dot de
pkgname='disk-test'
-_pkgverUpstream="0.1.1"
+_pkgverUpstream="0.2.0"
pkgver="${_pkgverUpstream//-/.}"
-pkgrel=3
-pkgdesc="Block device read-write test utility"
+pkgrel=1
+pkgdesc="Block device read-write test utility written in bash"
arch=('any')
-url='https://eomanis.duckdns.org/permshare/disk-test/index.xhtml'
+url='https://eomanis.duckdns.org/permshare/disk-test/'
license=('GPL3')
-depends=('bash' 'coreutils' 'openssl' 'pv' 'diffutils' 'grep' 'util-linux')
+depends=('bash' 'coreutils' 'diffutils' 'grep' 'openssl' 'pv' 'sed' 'util-linux')
source=("https://eomanis.duckdns.org/permshare/disk-test/disk-test-${_pkgverUpstream}.tar.gz")
-sha384sums=('5ccea4af83191bcff48b8440c6da8d10f9874fdc396b8f197ad400c759a8b98f0c163b917527bbe17b5556e317182047')
+sha384sums=('0e90c7dc26bfc45b3b0c3876e30747f3e92e9303d9922c647dc1da67e8ffa46d2b39bdba2d38ea0d05394f35ffd65474')
package() {
+ local srcRootDir="${srcdir}/${pkgname}-${_pkgverUpstream}"
# Place the main bash script into /usr/bin
mkdir -p "${pkgdir}/usr/bin"
cd "${pkgdir}/usr/bin"
- cp -t . "${srcdir}/disk-test"
+ cp -t . "${srcRootDir}/disk-test"
chmod u=rwx,go=rx "disk-test"
}