summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorb1tl0rd2019-12-05 13:04:59 -0300
committerb1tl0rd2019-12-05 13:04:59 -0300
commit6824f543c807f569df499967eb7beb69390a8a71 (patch)
treee11ecdd6df5b3e0fd77a48d839317d4691e4a346 /PKGBUILD
downloadaur-6824f543c807f569df499967eb7beb69390a8a71.tar.gz
diskus-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8588a3f0708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Walter C <bitlord@disroot.org>
+
+pkgname="diskus-git"
+_pkgname="diskus"
+pkgver=0.6.0.85.g90fa0e3
+pkgrel=1
+pkgdesc="A command-line tool to generate, analyze, convert and manipulate colors"
+arch=("i686" "x86_64" "arm" "aarch64")
+url="https://github.com/sharkdp/diskus"
+license=("MIT" "Apache")
+depends=()
+makedepends=("rust" "cargo" "git")
+provides=("diskus")
+conflicts=("diskus")
+source=("$_pkgname::git+https://github.com/sharkdp/diskus.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ cargo build --release --locked
+}
+
+check() {
+ cd $_pkgname
+ cargo test --release --locked
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ for license in APACHE MIT
+ do install -Dm644 "LICENSE-$license" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE-$license"
+ done
+}