summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorabelian4242023-02-22 12:26:54 +0600
committerabelian4242023-02-22 12:26:54 +0600
commitd03b655aa6d5285684a9d42719f9a401c3f33ba3 (patch)
treea465d77154c9477e8dab6d58234926b0befb437e /PKGBUILD
parente42221fc9a97603b8fd718d58ede4c1b9ae13ff3 (diff)
downloadaur-d03b655aa6d5285684a9d42719f9a401c3f33ba3.tar.gz
Updated to 5.27 against Plasma/5.27 branch of disman
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3481e6016fa0..13a3fd1a3954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Author: Roman Gilg <subdiff@gmail.com>
pkgname=disman-kwinft
-pkgver=5.26.5.r1847.g8f7345c
+pkgver=5.27
pkgrel=1
pkgdesc='Qt/C++ display management library'
arch=(x86_64 aarch64)
@@ -14,17 +14,13 @@ makedepends=(extra-cmake-modules git kdoctools qt5-tools)
source=("git+https://gitlab.com/kwinft/disman.git")
sha256sums=('SKIP')
-pkgver() {
- _ver=5.26.5
- cd disman
- echo "${_ver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
-}
-
prepare() {
- mkdir -p build
+ cd disman
+ git checkout Plasma/$pkgver
}
build() {
+ mkdir -p build
cd build
cmake ../disman \
-DCMAKE_BUILD_TYPE=Release \