summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Appelt2020-08-11 19:39:24 +0200
committerDaniel Appelt2020-08-11 19:39:24 +0200
commit868f1a9a627acb46157d634193045510765a4118 (patch)
treeb73b1077842a75f09db71c02f4bda8f2a3dbcf95 /PKGBUILD
parent719eedb6cfe36678e8f2eb8be247e2a5eedbb63e (diff)
downloadaur-868f1a9a627acb46157d634193045510765a4118.tar.gz
Correct meson build configuration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a625e1cdebcc..c5deb69e6707 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbasename=distrho-lv2
pkgname=${_pkgbasename}-git
pkgver=r492.062a0f61
-pkgrel=1
+pkgrel=2
pkgdesc="Distrho LV2 Audio Plugins, using the JUCE Toolkit"
arch=('i686' 'x86_64')
url="http://distrho.sourceforge.net/"
@@ -24,15 +24,13 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgbasename}"
+ meson configure build -Dprefix="${pkgdir}/usr" -Dbuild-vst2=false -Dbuild-vst3=false
meson build --buildtype release
ninja -C build
-# ninja -C build install
}
package() {
cd "${srcdir}/${_pkgbasename}"
- # lv2 plugins
- install -d "$pkgdir/usr/lib/lv2"
- cp -a bin/lv2/*.lv2 "$pkgdir/usr/lib/lv2"
+ ninja -C build install
}