summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorluxcem2020-02-20 18:45:32 +0100
committerluxcem2020-02-20 18:45:32 +0100
commit006b8f519719fd799c8ad2735f4962638edcb0cc (patch)
tree41aa478378fa706aa29c600c8b3336f3092f7348 /PKGBUILD
parent6ef187926675d0223c80b12f1b12ca975b18a265 (diff)
downloadaur-006b8f519719fd799c8ad2735f4962638edcb0cc.tar.gz
Update to v3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1065029cfb6e..e27068da3e8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: Andrejs Mivreņiks <gim at fastmail dot fm>
+# Maintainer: luxcem <a@luxcem.fr>
+# Contributor: Andrejs Mivreņiks <gim at fastmail dot fm>
# Contributor: Apkawa <apkawa at gmail dot com>
pkgname=django-docs
-pkgver=2.1
+pkgver=3.0
pkgrel=1
pkgdesc="Docs for Django's release"
arch=('any')
url='https://docs.djangoproject.com/en/'
license=('GPL')
makedepends=('unzip')
-source=("https://docs.djangoproject.com/m/docs/django-docs-${pkgver}-en.zip")
+source=("https://media.djangoproject.com/docs/django-docs-${pkgver}-en.zip")
noextract=("django-docs-${pkgver}-en.zip")
-# They make minor changes to the ZIP archive contents every now and then,
-# so we have to skip hash sum check.
-sha256sums=('SKIP')
+# We check sha256 but we will see if it does change even if pkgver doesnt
+sha256sums=('af0eb41a4756f3108fb39cbf15812044bda535e87c1395806312864f3c4d113e')
prepare() {
- unzip "django-docs-${pkgver}-en.zip" -d "$srcdir/html"
+ unzip -oq "django-docs-${pkgver}-en.zip" -d "$srcdir/html"
}
package() {
install -d "${pkgdir}/usr/share/doc/django/"
cp -r "$srcdir/html" "${pkgdir}/usr/share/doc/django/"
}
-