summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:57:18 +0200
committerLubosz Sarnecki2015-06-22 22:57:18 +0200
commit3c0eb378581b0b098257b95e0ae15eee40f49747 (patch)
tree4cd11530c530954f958952e88b6e271fc920793e /PKGBUILD
downloadaur-3c0eb378581b0b098257b95e0ae15eee40f49747.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c667294f03f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Contributor: Jonathan Liu <net147@gmail.com>
+
+name=django-profiles
+pkgname=$name-hg
+pkgver=0.2.25.c21962558420
+pkgrel=1
+pkgdesc="A simple, generic user-profile application for Django"
+arch=('any')
+url="http://bitbucket.org/ubernostrum/django-profiles/wiki/Home"
+license=('BSD')
+depends=('python-django')
+makedepends=('python-distribute')
+provides=($name)
+conflicts=($name)
+source=("hg+https://bitbucket.org/ubernostrum/django-profiles")
+md5sums=("SKIP")
+
+pkgver() {
+ cd $name
+ vers=$(grep "version=" setup.py | sed "s/ version='//g" | sed "s/',//g")
+ echo $vers.$(hg identify -n).$(hg identify -i)
+}
+
+build() {
+ cd $name
+ python setup.py build
+}
+
+package() {
+ cd $name
+ python setup.py install --root="$pkgdir" -O1
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: