summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit45a35169ae73b752954f5d391da2df9c6c75a207 (patch)
tree178073346821b7d3ddbc66b94c8a196d01551a78 /PKGBUILD
downloadaur-45a35169ae73b752954f5d391da2df9c6c75a207.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48416b914427
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=djvubind
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='A tool to create highly compressed djvu files with ocr, metadata, and bookmarks'
+arch=('any')
+url='http://code.google.com/p/djvubind/'
+license=('GPL3')
+depends=('python' 'djvulibre' 'imagemagick' 'tesseract')
+makedepends=('python')
+optdepends=('minidjvu: for higher black-and-white compression'
+ 'cuneiform: an alternative OCR system')
+source=(http://djvubind.googlecode.com/files/$pkgname-$pkgver.tar.bz2
+ djvubind-1.2.1-compress.patch)
+md5sums=('027ee90fec7d6ee5ee921eebfae1dc2d'
+ '6fb6019bbc7e0171241399a145ef0b25')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver/unittests"
+ python3 ./unittests.py
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for i in ../*.patch; do
+ patch -i "$i" -p1
+ done
+
+ python3 ./setup.py install --root "$pkgdir"
+}