summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Gottula2023-10-22 16:49:44 -0700
committerJustin Gottula2023-10-22 16:49:44 -0700
commita63beb02226b793c8d2c96c6fedca6727662ddbc (patch)
treedb2c409e76322f1cc6dab441970d8a72800bde02 /PKGBUILD
parent6f3768bfc5d525c3c141b12b3f247da496a0845a (diff)
downloadaur-a63beb02226b793c8d2c96c6fedca6727662ddbc.tar.gz
Update tarball checksum; add patch to fix the build on kernel 6.4+
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d26c15b83fd5..6cabbe043f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Tom < reztho at archlinux dot us >
# Thanks to contributors/mantainers of frandom and dkms-nvidia packages
# since I used those packages as templates to make this one
+# Contributor: Justin Gottula <justin@jgottula.com>
pkgname=dkms-frandom
pkgver=1.2
-pkgrel=2
+pkgrel=3
pkgdesc="A very fast random number generator kernel module (DKMS version)"
arch=('any')
url="http://frandom.sourceforge.net/"
@@ -16,12 +17,14 @@ conflicts=("frandom")
options=(!strip)
_pkgname=frandom
source=("http://www.billauer.co.il/download/${_pkgname}-${pkgver}.tar.gz"
+'linux-6.4-compat.patch'
'frandom.udev.patch'
'dkms.conf'
'Makefile')
build() {
cd "$srcdir/$_pkgname-${pkgver}"
+ patch -p1 -i "$srcdir/linux-6.4-compat.patch"
patch -p1 -i "$srcdir/frandom.udev.patch"
}
@@ -33,7 +36,8 @@ package() {
install -m644 "$srcdir/Makefile" "$pkgdir/usr/src/$_pkgname-$pkgver"
}
-md5sums=('a4b60abb11799dda965694331e5b0785'
+md5sums=('4b862b8723ff9cedcab3a7c4feeaee42'
+ '7349887f821ad71795cfdafeb41f16fb'
'a41a534a4b732a6e2a0b41214fa27a1d'
'b8943c145912d5da71dd84e54465bb85'
'1e94254311f05274035b5e41ff5a7a33')