summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2016-03-07 03:24:00 +0900
committerQue Quotion2016-03-07 03:24:00 +0900
commite2fe464e24b0a35e3798d49230d6c0c0e88f9460 (patch)
treef446b3e04f7c7c10cb9325909b8a8c8cace3fd8a /PKGBUILD
downloadaur-e2fe464e24b0a35e3798d49230d6c0c0e88f9460.tar.gz
Japanese Earthsoft PT3 driver for recpt1 controller, etc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be6193434527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Que Quotion <quequotion at gmail dot com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=dm2-alsa
+pkgver=r651
+pkgrel=1
+epoch=1
+pkgdesc='Mixman DM2 ALSA driver'
+arch=('i686' 'x86_64')
+url='https://sourceforge.net/projects/dm2linux/'
+license=('GPL2')
+depends=('alsa-lib')
+makedepends=('svn')
+provides=('${pkgname}'='${pkgver}')
+install=dm2-alsa.install
+source=('svn+svn://svn.code.sf.net/p/dm2linux/code/trunk'
+ thatfix)
+sha256sums=('SKIP'
+ '9dd4e03673f6eba409f44227348e06d7e7b28200c98a53f08c1406bb4cd0a10b')
+
+pkgver() {
+ cd "$srcdir/trunk"
+ echo "r$(svnversion)"
+}
+
+prepare() {
+ cd trunk/dm2_alsa/
+ patch -Np3 < ../../thatfix
+}
+
+build() {
+ cd trunk/dm2_alsa/
+ make
+}
+
+package() {
+ cd trunk/dm2_alsa/
+
+ make DESTDIR="${pkgdir}/usr/" install
+}
+