summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Dray2015-07-05 18:12:08 +1000
committerJustin Dray2015-07-05 18:12:08 +1000
commit64f884b72dbc9a7188b59394ec99a812e089b394 (patch)
tree8e5d11a65fea762418d46bcc8a46b89d5d24114f /PKGBUILD
downloadaur-64f884b72dbc9a7188b59394ec99a812e089b394.tar.gz
Update to: r16.177fd14-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2754cd6003f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Justin Dray <justin@dray.be>
+
+pkgname=dmakepkg-git
+pkgver=r16.177fd14
+pkgrel=1
+pkgdesc='Makepkg running from within docker for clean builds without maintaining a chroot'
+arch=('any')
+url="https://github.com/justin8/docker-makepkg"
+license=('MIT')
+depends=('docker')
+options=(!emptydirs)
+source=(git+https://github.com/justin8/docker-makepkg.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd docker-makepkg
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${srcdir}/docker-makepkg/dmakepkg" "${pkgdir}//usr/bin/dmakepkg"
+}