summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBarbUk2022-04-26 09:09:28 +0200
committerBarbUk2022-04-26 09:09:28 +0200
commitc75ed85cc15bbb4f5e241cd8e070d820b8fa523a (patch)
tree8c7c4edada8122f9a7e432525157b48006a5ac1c /PKGBUILD
downloadaur-c75ed85cc15bbb4f5e241cd8e070d820b8fa523a.tar.gz
Release package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f03658cfa24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Julien Virey <julien.virey@gmail.com>
+
+pkgname=dmarc-cat
+pkgver=0.15.0
+pkgrel=1
+pkgdesc='Small utility to decode the report sent by various email providers following the DMARC spec'
+arch=('x86_64')
+url='https://github.com/keltia/dmarc-cat'
+license=('Custom')
+conflicts=("${pkgname}-git")
+makedepends=(go)
+source=("dmarc-cat::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('886bf33ba60d601de74a1e9d437a8e09eea5c03a05b09c0f685fa02d1c174bba')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags $LDFLAGS" \
+ -o $pkgname
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE.md -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}