summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBarbUk2023-03-30 12:12:00 +0200
committerBarbUk2023-03-30 12:12:00 +0200
commitf87c3b11294a74a24cbe3a10438223894bd6b89c (patch)
tree4c695c881179bb68125140ff5a3d02b85c24d6b4 /PKGBUILD
parentbd6803fe43e504659343b35432b50d4455d7250e (diff)
downloadaur-f87c3b11294a74a24cbe3a10438223894bd6b89c.tar.gz
Update package with recent archlinux Go_package_guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1193841b102f..159f818daa7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dmarc-cat
pkgver=0.15.0
-pkgrel=2
+pkgrel=3
pkgdesc='Small utility to decode the report sent by various email providers following the DMARC spec'
arch=('x86_64')
url='https://github.com/keltia/dmarc-cat'
@@ -14,11 +14,13 @@ sha256sums=('886bf33ba60d601de74a1e9d437a8e09eea5c03a05b09c0f685fa02d1c174bba')
build() {
cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+
go build \
- -trimpath \
- -buildmode=pie \
- -mod=readonly \
- -modcacherw \
-ldflags "-linkmode external -extldflags $LDFLAGS" \
-o $pkgname
}