summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmilio Reggi2022-08-12 14:51:35 +0200
committerEmilio Reggi2022-08-12 14:51:35 +0200
commit7690e86b20b5142f378653617b9a29669b82b189 (patch)
tree57cfd6e20e062e2e74ccd34511f853c61a0cc79e /PKGBUILD
parentc94097bf95ea2da875874c1316b4b7b01c775d39 (diff)
downloadaur-7690e86b20b5142f378653617b9a29669b82b189.tar.gz
update to new install routine
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c7cedb00625..79a3572507c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=dmenu-extended-git
_pkgname=dmenu-extended
_source=https://github.com/markjones112358/dmenu-extended.git
-pkgver=r358.16bde81
-pkgrel=2
+pkgver=r418.3639b0e
+pkgrel=1
pkgdesc='An extension to dmenu for quickly opening files and folders and run programs.'
url='https://github.com/markjones112358/dmenu-extended'
license=('MIT')
@@ -25,11 +25,11 @@ pkgver() {
build() {
cd "$_pkgname"
- python setup.py build
+ python3 -m build --wheel --no-isolation
}
package() {
cd "$_pkgname"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}